Einwahlprobleme mit KInternet unter Suse 9.2. Home - mal geht`s, mal nicht

Ralf Rickert - Donnerstag, 24. Februar 2005 09:57:49 - 7 Antworten

Hallo,
ich habe auf meinem Rechner Suse 9.2. Personal installiert. Ich möchte Linux hauptsächlich zum Surfen im Internet nutzen, da mir das sicherer als Windows erscheint. Mein Linux-Wissen ist daher sicherlich nur sehr bescheiden, aber das will und werde ich ändern.

Folgendes Problem habe ich mit meinem Rechner.

Ich nutze eine PCI-FritzCard mit dem HISAX-Treiber von Suse. Wenn ich mich mit KInternet einwählen will schlägt dies sehr oft fehl und ich bekomme unter "Verbindung prüfen" folgende Hinweise:

Ungültige Standard Route. Kann Datei /proc/net/route nicht lesen: Erfolg
Nameserver-Fehler: Kann Datei /etc/resolv.conf nicht lesen: Keine Berechtigung.

Dann fahre ich den Rechner runter und wieder hoch, und komischerweise funktioniert die Einwahl dann, oder auch nicht. Irgendwann, nach 5-10 mal runterfahren und wieder rauffahren funktioniert es dann.

Am Internetprovider kann es nicht liegen, da es unter Windows mit dem gleichen Provider ohne Probleme anstandslos und sofort funktioniert.

Kann mir evtl. jemand helfen, wo hier der Fehler zu suchen und wie er zu beheben ist? Wie gesagt, ich bin Laie und stehe jetzt echt vor einem Rätsel.
Danke schon einmal,
Gruß, Ralf

Antworten
Re: Einwahlprobleme mit KInternet unter Suse 9.2. Home - mal geht`s, mal nicht [NACHTRAG]
Thorsten Szukies, Donnerstag, 24. Februar 2005 21:48:21
Ein/Ausklappen

Wenn du die "Anleitung" abgearbeitet hast und bei Standardroute ein OK steht, aber beim Nameserver es noch nicht in Ordnung ist...dann einfach mal auf AKTUALISIEREN klicken. Bei mir hat's so immer geklappt.

MfG
Thorsten S.


Bewertung: 180 Punkte bei 28 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Einwahlprobleme mit KInternet unter Suse 9.2. Home - mal geht`s, mal nicht [NACHTRAG]
Ralf Rickert, Freitag, 25. Februar 2005 08:00:19
Ein/Ausklappen

Hallo,

vielen Dank für Deine Tipps. Habe es ausprobiert, aber leider funktioniert es auch so nicht. Ich bin kurz davor, Suse 9.2 runter zu schmeißen und mir eine andere Distribution zu holen.

Vielen Dank noch einmal, Gruß Ralf


Bewertung: 184 Punkte bei 30 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Einwahlprobleme mit KInternet unter Suse 9.2. Home - mal geht`s, mal nicht [NACHTRAG]
Vinzenz Schmid, Freitag, 25. Februar 2005 08:18:12
Ein/Ausklappen

Der Einwähler Kinternet ist ein proggy von KDE.org und hängt mit dem KDE-Desktop zusammen, nicht mit der Distribution wie SuSE 9.2. Mit anderen Distris würde das Problem nicht lösbar sein. Ich denke in erster Linie an eine schlechte Installation und vor allem mit einem Berechtigungsproblem (Namenserver: fehlende Berechtigung). Was ich nun unternehmen würde (bin selber kein Informatiker):
1) Mich als root anmelden und kinternet starten und das Protokollfenster beobachten (mit rechtem Mausklick auf kinternet-Symbol drücken und da hats eine menüoption). Wenn das Einwählen klappt, dann wars ein Berechtigungsproblem.
2) Bei Berechtigungsproblem. Diesen Namenserver, die Sie oben erwähnt haben, für Sie als user zu berechtigen.
3) Kinternet weginstallieren und dann neu installieren.

Aber damit die anderen Ihnen präzise weiterhelfen können, müssen Sie uns die Protokoll (Log)-Informationen hier posten.


Bewertung: 183 Punkte bei 28 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Einwahlprobleme mit KInternet unter Suse 9.2. Home - mal geht`s, mal nicht [NACHTRAG]
Ralf Rickert, Freitag, 25. Februar 2005 11:06:11
Ein/Ausklappen

@ vinzenz schmidt

Vielen Dank für Ihre Hinweise. Ich werde mich am Wochenende noch einmal meinem Problem widmen und Ihre Hinweise abarbeiten. Eine Neuinstallation wäre wirklich die letzte Lösung. Vielen Dank, ich melde dann nächste Woche, ob es geklappt hat oder nicht.
Schönes Wochenende !



Bewertung: 152 Punkte bei 26 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Einwahlprobleme mit KInternet unter Suse 9.2. Home - mal geht`s, mal nicht [NACHTRAG]
Werner Gohl, Samstag, 26. Februar 2005 10:09:03
Ein/Ausklappen

so langsam bekomme ich das Gefühl, dass der Fehler in einer ganz anderen Ecke zu suchen ist?
Schau mal auf diese Seite hier im Forum, ich habe das gleiche Problem unter ganz anderen hardware-Bedingungen:

http://www.linux-community.de/Neues/story?storyid=15867

Erst heute Morgen musste ich 2mal booten um mich anmelden zu können.
In meiner "Not" habe ich mich neulich an einen SuSE-Entwickler direkt gewandt, und siehe da, huier der O-Ton:

On Mon, Feb 21, 2005 at 11:58:36AM +0100, Werner Gohl wrote:

>> hallo xyz,
>>
>> nur sehr ungern wende ich mich an die Entwickler direkt, ihr habt
>> wichtigeres zu tun...
>> Trotzdem bitte ich um einen Tip in folgender Sache, die ich unter dieser url
>> http://www.linux-community.de/Neues/story?storyid=15867
>> ins Forum gestellt habe, so recht kann dort keiner helfen.


Beste Adresse fuer diese Probleme ist die suse-isdn Mailingliste, dort lesen
auch andere Entwickler mit, ua. auch von AVM.


>>
>> Warum klappt die DSL-Einwahl viele male, und dann plötzlich geht nichts
>> mehr, ich muss die ISDN-Konfig durchgehen, dann geht's wieder?


Also YaST macht am Ende der Konfiguration nichts weiter als ein:

rcnetwork stop
rcisdn stop
rcisdn start
drdsl
rcnetwork start

Alle anderen Sachen der Konfiguration koennen keinen Einfluss haben.

Ich habe hier auch festgestellt, das wenn der Anschluss mal gestoert war,
(zum Beispiel weil ich ein anderes Testsystem ausprobiert habe und
die Leitung einfach umgesteckt habe) es teilweise notwendig war alles neu zu
starten, in Einzelfaellen musse ich den Rechner neu booten (mit ausschalten)
damit wieder eine Verbindung moeglich war. Da es durchaus normal ist, das
DSL Anschluesse ab und zu mal (meistens unbemerkt) fuer kurze Zeit eine
Stoerung haben, kann es durch aussein das manchmal dann auch waehrend des
normalen Betriebs soetwas passieren kann.


>>
>> Eine Erneuerung des fcdslsl traue ich mir nicht zu, wer weiss, was dann
>> passiert, halte ich auch nicht für nötig, siehe Text von der avm.de :
>>


Ist nicht notwendig, unsere Kernelupdates enthalten immer die aktuellen
Versionen.


>> _______________________________________________________________________________
>>
>> This directory includes an archive with all necessary files for
>> the package "CAPI4Linux".
>>
>> This directory contains the following components:
>> - CAPI 2.0 driver of the controller
>> - CAPI 2.0 plug-in for the Generic PPP-Stack "pppd"
>>
>> CAPI 2.0 driver for the controller and pppd plug-in contain precompiled
>> modules for SuSE-Linux. To allow manually integration in other
>> distributions
>> or kernel versions (makefiles), the sourcecode is included as well.
>> The archives in this directory contain the current packages.
>> Please copy the file to your computer and extract the file
>> with the command tar -xzvf
>>
>> A subdirectory containing the installation files will be created
>> automatically.
>> Install the software from this dirctory according to the installation
>> instructions
>> in the files "INSTALL_PASSIVE-d.HTML" / "INSTALL_PASSIVE-e.HTML"
>> This archive includes the software for the following modules:
>>
>> Archive : fcdslsl-suse9.1-03.11.03.tar.gz
>> Modul : CAPI2.0-driver for the AVM DSL-Controller FRITZ!Card
>> DSL SL
>> Modul : CAPI2.0 plug-in for the Generic PPP-Stack "pppd"
>> Operating system: Linux - Kernel 2.6.4-52; SUSE 9.1 Pro. and other
>> distributions (Makefile)
>> Version : 03.11.04
>> Build : 04.06.17
>> _________________________________________________________________________________
>> Note: In SUSE Linux 9.0 or higher an AVM CAPI4Linux driver is already
>> integrated
>> into the operating system.
>>


ein schönes Einwahl-Übungs-Wochenende an die Gemeinde...
Werner


Bewertung: 204 Punkte bei 28 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Einwahlprobleme mit KInternet unter Suse 9.2. Home - mal geht`s, mal nicht [NACHTRAG]
Ralf Rickert, Montag, 07. März 2005 17:35:24
Ein/Ausklappen

Hallo,

danke an alle die mir helfen wollten. Ich habe die Tipps ausprobiert, aber leider war keine Besserung zu verzeichnen. Da ich mit einem System einfach nur arbeiten will, nicht permanent irgendwelche Systemeinstellungen ausprobieren will und ich wohl auch letztlich zu ungeduldig bin habe ich letzte Woche die Suse Installation gelöscht und Kanotix installiert. Und siehe da, alles läuft wunderbar. Ich bin total begeistert davon. Was mir besonders gefällt, ist die einfache Möglichkeit zur Programminstallation mit "Klik".
Vielen Dank trotzdem noch einmal für die Tipps und Hinweise.
Gruß, Ralf


Bewertung: 114 Punkte bei 23 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Einwahlprobleme mit KInternet unter Suse 9.2. Home - mal geht`s, mal nicht
Thorsten Szukies, Donnerstag, 24. Februar 2005 12:42:17
Ein/Ausklappen

Ich hatte bzw. habe ein ähnliches Problem...
Hallo Ralf!
Vielleicht kann ich dir aber helfen...
Ich benutze zwar keine PCI-ISDN Karte sondern einen Router. Aber ich denke das die Netzverbindung dazu analog ist.
Immer wenn ich den Router brauche, dann schalte ich ihn ein...und wenn ich den Rechner hochfahre dann komme ich oft nicht ins Internet...nur manchmal hab' ich Glück.
Kontrolliere bitte zunächst mal was KInternet sagt. Klicke mit der rechten Maustaste auf das kleine Steckerchen unten rechts in der Leiste und schaue nach ob die richtige Schnittstelle ausgewählt ist und dementsprechend ein Häkchen davor ist; dann noch auf Verbindung prüfen klicken...was steht dann da? Wenn bei Standart-Gateway und Nameserver jeweils ein OK und IP-Adressen stehen ist alles ok und du solltest ins Internet kommen. Wenns bei beiden oder auch nur bei einem nicht ok da steht, versuche mal bitte folgendes. Ich muss auch oft so vorgehen...
Wenn ich den Rechner hochgefahren habe und ins Netz möchte muss ich immer Trick machen -->
Ich mache eine Konsole auf und melde mich als Root an, danach gebe ich diese beiden Befehle ein:
rm /var/run//dhcpcd-eth1.pid
dhcpcd eth1
Das Device (eth*) ist entsprechend auzupassen...je nachdem wie viele Netzwerkkarten du hast.
Wenn der zweite Befehl durchgelaufen ist, dann einmal auf die Enter-Taste drücken um das Prompt wieder zu sehen (ist zumindest bei mir der Fall).
Dann noch einmal die beiden Kontrollschritte mit dem Rechtsklick auf das Steckerchen machen und nun müsste bei Standard-Gateway und Nameserver beide mal ein OK stehen und du solltest ins Internet kommen.
Ich werde mal ein kleines Skript schreiben für mich das die beiden Befehle bei jedem Systemstart ausführt.
ich hoffe ich konnte dir helfen...
Sag mal, ob's funzt...

MfG
Thorsten S.


Bewertung: 177 Punkte bei 30 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Ins Internet mit DSL, ISDN oder Modem
    Suse Linux unterstützt zur Internet-Anbindung die gesamte Palette verfügbarer Technologien. Wir zeigen Ihnen, wie Sie sich per DSL, ISDN oder Modem mit dem Netz der Netze verbinden.
  • Ausgebremst
    Steht Ihnen kein Breitbandanschluss zur Verfügung und besitzen Sie kein ISDN, hilft nur der Griff zum Analogmodem, um ins Internet zu kommen. Welche Gerät Linux-tauglich sind, zeigt dieser Artikel.
  • Online im Grünen
    Dein DSL, kein ISDN? Kein Problem. Mit aktuellen UMTS-Karten und einer Flatrate surfen Sie auch kabellos mit akzeptablem Speed und moderaten Kosten. LinuxUser zeigt, wie es funktioniert.
  • Verbindungen
    Die echten Vorteile von Linux gegenüber Windows zeigen sich erst im Netzwerk so richtig. Dieser Artikel erklärt, wie Sie unter OpenSuse per Modem, ISDN, DSL und WLAN ins Internet kommen.
  • Yakumo Power E-Net USB unter Linux

Aktuelle Fragen

Wifikarte verhindert Bootvorgang
Maik Kühn, 21.01.2018 22:23, 1 Antworten
iwlwifi-7265D -26 failed to load iwlwifi-7265D -25 failed to load iwlwifi-7265D -24 failed to l...
sharklinux
Gerd-Peter Behrendt, 18.01.2018 23:58, 2 Antworten
Hallo zusammen, ich habe sharklinux von der DVD Installiert. 2x, jedesmal nach dem Reboot ist di...
Anfänger sucht Ratschläge
Alucard Nosferatu, 18.01.2018 21:56, 3 Antworten
Guten Tag, meine Wenigkeit würde gerne auf einer meiner Festplatten von meinen Feldrechnern e...
Suchprogramm
Heiko Taeuber, 17.01.2018 21:12, 1 Antworten
Hallo liebe Community, keine Ahnung ob dieses Thema hier schon einmal gepostet wurde. Ich hab...
Linux Mint als Zweitsystem
Wolfgang Robert Luhn, 13.01.2018 19:28, 4 Antworten
Wer kann mir helfen??? Habe einen neuen Laptop mit vorinstaliertem Windows 10 gekauft. Möchte g...

Stellenmarkt

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Debian_Testing:_Unklare_Meldung_zwischen_GRUB_und_Entschlüsselung_der_Festplatte
"Michael R. Moschner", 23.01.2018 18:30
Am Dienstag, 23. Januar 2018, 08:43:29 schrieb Uwe Herrmuth: Hallo Uwe Letzte Kernelupdate war wenige Minut...
Re: [EasyLinux-Ubuntu] Debian_Testing:_Unklare_Meldung_zwischen_GRUB_und_Entschlüsselung_der_Festplatte
Uwe Herrmuth, 23.01.2018 08:43
Hallo Michael, Michael schrieb am 22.01.2018 um 18:56: > Ich habe seit mehr als einem Jahr ein Think Pad...
[EasyLinux-Ubuntu] Debian_Testing:_Unklare_Meldung_zwischen_GRUB_und_Entschlüsselung_der_Festplatte
nobbynobbs@directbox., 22.01.2018 18:56
Hallo Liste Ich habe seit mehr als einem Jahr ein Think Pad Yoga 11. Installiert ist Debian Testing auf ein...
Re: [EasyLinux-Ubuntu] Stefan Neumayer schon lange nicht mehr aktiv?
Nguyen Dong Loan, 21.01.2018 10:10
Am Sonntag, den 07.01.2018, 15:18 +0100 schrieb Gerhard Blaschke: Hallo Gerhard > > weiß jemand, w...
Re: [EasyLinux-Ubuntu] Mail von Smart (2x)
Heiko Ißleib, 20.01.2018 03:56
Hallo Udo. Da habe ich eine viel schlechtere Platte,die jetzt fast 9 Jahre läuft. Gruß Heiko.