DNS Konfigurationproblem

Dirk Janczek - Dienstag, 29. November 2005 16:41:30 - 3 Antworten

Moin...
Ich habe ein problem mit dem BIND DNS Server 9.
Ich habe einen BIND DNS Server für die domin janczek.local aufgesetzt.
Intern löst er auch alles korrekt auf und die weiterleitung ins I-Net funktioniert auch prächtig.

Da ich für mich zum testen demnächst einen Windows 2003 Server mit Activ Directory zum testen aufsetzen muß, wollte ich gerne den internen von Microsoft benutzen. Er sollte den namen activ.janczek.local bekommen. Wie bekomme ich den Bind dazu das er alle anfragen nach activ.janczek.local auf den MS DNS Server leitet und dieser das auch beantwortet.
Ich möchte nicht das ich die Activ Directory Geschichte auf meinem sauberen BIND DNS Server landet da es nur ein kurzer Test sein sollte und die MS Kiste auch nicht 24Std. die Woche laufen soll.

Die internen Clients haben alle die IP vom BIND DNS Server eingetrgen.

Interner Bind: 192.168.1.10
Gateway Router wo Bind seine externe Anfragen abfragt: 192.168.1.1
MS DNS: 192.168.1.200

Antworten
Re: DNS Konfigurationproblem
Jörg Michels, Mittwoch, 30. November 2005 10:43:29
Ein/Ausklappen

Hallo Dirk,

wie du den Microsoft Teil konfigurierst, kann ich dir nicht sagen; aber den Bind Teil:

Als erstes mußt du dem Bind den Namen des Active Directory Servers bekannt machen. etwas so

msdns IN A 192.168.1.200 dann kannst du eine Sublevel-Domain angeben mit:

active IN NS msdns.janczek.local. Das wars schon auf Bind-Seite. Wichtig ist, dass NS-Records nicht auf CNames verweisen dürfen und dass Bind den Record auch auflösen kann (Stichwort: glue-Records).

Viele Grüße,
Jörg




Bewertung: 117 Punkte bei 23 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: DNS Konfigurationproblem
Dirk Janczek, Mittwoch, 11. Januar 2006 09:20:04
Ein/Ausklappen

Moin Moin...
Da bin Ich wieder nach langer Abstinenz.....beruflicher Natur.

So wie es Jörg oben beschrieben geht es bei mir nicht.
Ich versuche mich jetzt noch detailierter Auszudrücken.
Verzeit mir Fehler fange mit dem DNS Thema erst jetzt richtig an.

Ausgangssituation:

1.DNS-Server

Hardware: Linksys NSLU2 auf Unslung 5.5 Firmware geflasht.
Darauf läuft der Bind DNS Server in der Version 9.3.1.
IP Addr.: 192.168.1.10
Domain: janczek.local
Hostname: nas
Kompletter Name des Rechners "nas.janczek.local"


Datei: named.conf

options {

directory "/opt/etc/named";

# Forwarding auf dem Router fuer das I-Net
forwarders { 192.168.1.1; };

forward first;

listen-on-v6 { none; };

allow-query { 127.0/16; 192.168.1/24; };

notify no;

};

# Zoneconfig

zone "." in {
type hint;
file "local/root.hint";
};

zone "localhost" in {
type master;
file "local/localhost.zone";
};

zone "0.0.127.in-addr.arpa" in {
type master;
file "local/127.0.0.zone";
};

##############################################################


zone "janczek.local" {
type master;
file "master/janczek.local";
};


zone "1.168.192.in-addr.arpa" {
type master;
file "master/192.168.1.zone";
};


Datei: janczek.local -->> Zonendatei

$TTL 3600
janczek.local. IN SOA nas.janczek.local. hostmaster.janczek.localhost. (
1 ; serial
360000 ; refresh
3600 ; retry
360000 ; expire
3600 ; minimum
)
IN NS nas.janczek.local.

; Localhost

localhost.janczek.local. IN A 127.0.0.1


; NAS Linksys NSLU2

nas.janczek.local. IN A 192.168.1.10
nas1.janczek.local. IN A 192.168.1.11


; AccessPoint Config

fritz.janczek.local. IN A 192.168.1.1
ap1.janczek.local. IN A 192.168.1.2
ap2.janczek.local. IN A 192.168.1.3
ap3.janczek.local. IN A 192.168.1.4


; Grundconfig fuer Subdomain ACTIVE.JANCZEK.LOCAL

active.janczek.local. IN NS active.active.janczek.local.

active.active.janczek.local. IN A 192.168.1.210

;Das habe ich auch so mal versucht und aber auch den Weg den Jörg mir genannt hatte


2. DNS-Server

Hardware: Standart Rechner
Software: Windows 2003 Enterprise Server mit SP1 und allen Patches lt. Windows Update.
DNS Server: Orginaler der bei MS dabei ist.
IP: 192.168.1.210
Sub-Domain: active.janczek.local
Hostname: active
Kompletter Name des Rechners "active.active.janczek.local"



So nun zu meinem Problem:

Wie bekomme ich die beiden Server zusammen,so das ich sowohl ???.janczek.local und ???.active.janczek.local mit dem 1.DNS-Server (nas.janczek.local, IP: 192.168.1.10) abfragen kann???????

Also ich möchte erreichen das meine Clients auch den 2.DNS Server (MS-DNS) abfragen können.
Meine Clients haben alle nur die IP vom 1.DNS-Server (BIND-Linux) per DHCP bekommen. Dieses funtioniert auch alles sehr zuverlässig.
Ich kann alle adressen anpingen und auch aufrufen per NSLOOKUP, dort ist alles OK.
Rufe ich per NSLOOKUP active.active.janczek.local auf bekomme ich immer in Windows "unbekannte Domain".
Mache ich das auf der Linux Console das gleiche bekomme ich den fehler "unbekannte NXDOMAIN".

Ich hoffe ihr könnt mir helfen,DANK schon im voraus.

MFG Dirk


Bewertung: 79 Punkte bei 20 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: DNS Konfigurationproblem
Harald Geiger, Mittwoch, 11. Januar 2006 20:55:19
Ein/Ausklappen



Hallo Dirk,

ich hab hier mal die relevanten Zeilen der named.conf und der Zonendatei janczek.local zusammengestellt: options { # Forwarding auf dem Router fuer das I-Net forwarders { 192.168.1.1; }; forward first; }; zone "janczek.local" { type master; file "master/janczek.local"; }; active.janczek.local. IN NS active.active.janczek.local. active.active.janczek.local. IN A 192.168.1.210

Das heisst der Nameserver ist autoritativ für die Zone janczek.local nicht aber für die Zone active.janczek.local.

Ferner ist konfiguriert, dass der Nameserver alle Anfragen nach Domainnamen, für die der Nameserver nicht autoritativ ist, an den Forwarder 192.168.1.1 weiterleitet.

Der Router 192.168.1.1 weiss natürlich auch nichts mit irgendwas.active.janczek.local anzufangen und gibt die Anfrage an die Nameserver des Providers weiter. Die kennen die Domain natürlich auch nicht.

Damit die Namensauflösung so funktioniert, wie Du es Dir vorstellst, muss Dein Nameserver also entweder autoritativ für die Zone active.janczek.local werden oder die betreffenden Anfragen an den Active Directory Server 192.168.1.210 weiterleiten. Spontan fallen mir folgende Möglichkeiten ein:

1. Keine Forwarders für die Domain janczek.local
Das ist wohl die einfachste Lösung. Änderung in der Definition der Zone: zone "janczek.local" { type master; file "master/janczek.local"; forwarders { }; };

2. Einrichten einer Forward Domain speziell für active.janczek.local: zone "active.janczek.local" { type forward; forwarders { 192.168.1.210; }; forward only; };

3. Verzicht auf die DNS Forwarder von Router und Provider
Dein Nameserver führt dann alle Namensauflösungen selbst durch. # deaktiviert # Forwarding auf dem Router fuer das I-Net # forwarders { 192.168.1.1; }; # forward first;

4. Einrichten einer Slave Zone für active.janczek.local
Dann wäre der BIND autoritativ für active.janczek.local und würde die Zonendaten vom AD Server per Zonentransfer beziehen. Ist aber wohl zuviel Aufwand.

Harald


Bewertung: 118 Punkte bei 21 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Bind 10 soll diverse Nameserverprobleme lösen
    Nach zehn Jahren plant das herstellerunabhängige Internet Systems Consortium eine von Grund auf neue Version des marktführenden DNS-Nameservers Bind. Finanziert von Sponsoren soll alles sicherer, flexibler und skalierender werden, mit Details halten sich die Entwickler aber noch zurück.
  • Cebit 2010: DNS-Entwickler arbeiten an Bind 10
    In der Open Source Project Lounge in Halle 2 der Cebit geben die Entwickler von Bind 10 eine Vorschau auf die kommende Version des Nameservers und suchen Kontakt zur Community.
  • Unicode und Archivfunktion für die Groupware

    Pünktlich zum Partnertreffen Zarafa Summercamp hat der deutsch-holländische Groupwarehersteller eine neue Major Release seiner Kollaboration-Plattform veröffentlicht. Die bringt mehr Performance, Unicode und ein Archiv für Groupwaredaten mit.
  • PyGTK endet mit 2.24

    Der Doktorand John Stowers hat PyGTK, die Python-Bindings für das GTK+-Toolkit, in Version 2.24 veröffentlicht.
  • Konfiguration der Bash
    Für viele Einsteiger ist die Shell ein Mysterium, das fortgeschrittenen Anwendern und Linux-Gurus vorbehalten bleibt. Dabei verbirgt sich hinter dem Prompt ein flexibles Programm, mit dem Anwender beinahe jede Aufgabe lösen können.

Aktuelle Fragen

Linux open suse 2,8
Wolfgang Gerhard Zeidler, 18.04.2017 09:17, 2 Antworten
Hallo.bitte um Hilfe bei. Code fuer den Rescue-login open suse2.8 Mfg Yvo
grep und sed , gleicher Regulärer Ausdruck , sed mit falschem Ergebnis.
Josef Federl, 15.04.2017 00:23, 1 Antworten
Daten: dlfkjgkldgjldfgl55.55klsdjfl jfjfjfj8.22fdgddfg {"id":"1","name":"Phase L1","unit":"A",...
IP Cams aufzeichnen?
Bibliothek der Technischen Hochschule Mittelhessen / Giessen, 07.04.2017 09:25, 7 Antworten
Hallo, da nun des öfteren bei uns in der Nachbarschaft eingebrochen wird, würde ich gern mein...
WLAN lässt sich nicht einrichten
Werner Hahn, 21.03.2017 14:16, 2 Antworten
Dell Latitude E6510, Ubuntu 16.4, Kabelbox von Telecolumbus. Nach Anklicken des Doppelpfeiles (o...
"Mit Gwenview importieren" funktioniert seit openSuse 42.2 nicht mehr
Wimpy *, 20.03.2017 13:34, 2 Antworten
Bisher konnte ich von Digitalkamera oder SD-Karte oder USB-Stick Fotos mit Gwenview importieren....

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Gemeinsame Fotoablage im Haus
Nguyen Dong Loan, 24.04.2017 18:26
Am Montag, den 24.04.2017, 17:50 +0200 schrieb Marcello: Hallo Marcello > Die NAS-Systeme machen auc...
Re: [EasyLinux-Ubuntu] Gemeinsame Fotoablage im Haus
Marcello, 24.04.2017 17:50
Am 24. April 2017 09:27:09 MESZ schrieb Nguyen Dong Loan : >Am Sonntag, den 23.04.2017, 23:39 +0200 schrieb...
Re: [EasyLinux-Ubuntu] Gemeinsame Fotoablage im Haus
Nguyen Dong Loan, 24.04.2017 09:27
Am Sonntag, den 23.04.2017, 23:39 +0200 schrieb Marcello: Hallo Marcello > > Kennt ihr noch andere...
Re: [EasyLinux-Ubuntu] Gemeinsame Fotoablage im Haus
Uwe Herrmuth, 24.04.2017 09:00
Hallo Marcello, Marcello schrieb am 23.04.2017 um 23:39: > Ich hätte zwei Optionen: > 1. Nextcloud...
Re: [EasyLinux-Ubuntu] Gemeinsame Fotoablage im Haus
Gerhard Blaschke, 24.04.2017 06:07
Guten Morgen, Am 23.04.2017 um 23:39 schrieb Marcello: > Guten Tag, > > ich habe derzeit folgendes...