D-Link DGE-528T (Gigabit Ethernet Karte) unter Kernel 2.6 zum Laufen bringen

Ulf B. - Freitag, 12. August 2005 22:41:59 - 4 Antworten



Hallo allerseits,

habe leider ein HW-Problem. Trotz größter Sorgfalt (oberflächliche Recherche im Internet). Habe ich oben genannte Gigabit Ethernet Karte [1] bei einem Händler um die Ecke [2] gekauft (leider habe ich gegen meine Gewohnheit nicht im Internet bestellt). Nachdem ich die Karten (natürlich auch noch zwei) in meinem kleinen Heimserver eingebaut hatte, wurden diese zwar von YaST (SuSE 9.2 - mit allen YOU Patches - Kernel 2.6.8-24.17-default) sofort erkannt, ich konnte aber dennoch keine Verbindung aufbauen. Nach genauen Studium der Log Files konnte ich nichts erkennen (keine Einträge). Egal was ich unternommen habe in der
       ifconfig 
tauchte keine Ethernet Schnittstelle auf. Ich habe dann noch versucht die via Internetrecherche gefundenen Hinweise umzusetzen, und es gelang mir auch die Module
 r8169.ko 
oder
       ns83820.ko 
ohne Fehlermeldung zu laden, aber leider hat dieses keine Änderung bzw. Logausgabe verursacht.

Im Internet auf der deutschen D-Link Seite gibt es nur Treiber für MacOS und WinXX [3]. Auf der beiligenden CD gibt es zwar Sourcen für die Kernel 2.3 und 2.4, welche aber nicht unter 2.6 Compalierbar sind. Ich habe gestern (11.08.2005) zwar eine Mail an den Support [4] geschrieben, habe aber wenig Hoffnung auf eine sinnvolle Antwort.

Nun sitze ich da mit meinem kurzen Hemd, und weiß nicht mehr weiter. Mein Händler nimmt normalerweise keine geöffneten PC-Einsteckkarten zurück (er müßte diese ja dann Testen). Und ich habe keine WinXX PC's im Einsatz (100% WinXX freie Zohne - na gut auf dem Notebook is noch eine kleine WinXP Service Partition). Wer hat noch Tipps, weiß noch etwas anderes (z.B. ob noch SW für den Chipsatz (D-Link DLG10028) in Entwicklung ist).

PS: Die Karte hat für knappe 17 &eur; ein kleines Zusätlich beigelegtes Slotblech und ein 3 Poliges Kabel (ich nehme an für WOL (Wake On LAN)).

Ciao
Ulf

[1] http://www.d-link.de/?go=jN...8sAmu5j3cf/YEPAM7l1KPjKUgYuOs=
[2] http://www.hoerco.de
[3] http://www.d-link.de/?go=gN...vhLPG3yV3oUo9/hK4uP54hMKZj6T8p
[4] mailto:support@dlink.de

Antworten
Re: D-Link DGE-528T (Gigabit Ethernet Karte) unter Kernel 2.6 zum Laufen bringen
Stefan Günther, Samstag, 13. August 2005 13:11:20
Ein/Ausklappen

Hi,

fangen wir einmal mit den naheliegenden Dingen an:
Was bekommst Du als Antwort, wenn Du den folgenden Befehl eingibst:

ifconfig eth0 192.168.0.1

Wenn Dein Rechner die Module lädt, dann hat er die Hardware ja auch gefunden, dann müßtest Du der Karte auch eine IP zuweisen können. Falls nicht, dann erhälst Du vielleicht eine Fehlermeldung, die Dir/uns weiterhilft.

Viel Erfolg,

Stefan


Bewertung: 189 Punkte bei 49 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: D-Link DGE-528T (Gigabit Ethernet Karte) unter Kernel 2.6 zum Laufen bringen
Ulf B., Samstag, 13. August 2005 17:23:31
Ein/Ausklappen

Hallo Stefan,

wie ich oben schon geschrieben habe, taucht die Netzwerkkarte schon gar nicht unter ifconfig auf (nur die anderen Schnittstellen werden angezeigt wie z.B. lo und irda0 ). Auch in den LOG-Dateien gibt es nicht eine Zeile die etwas damit zu tun hat (keine Fehlermeldung oder sonst einen verwertbaren Eintrag).

Ciao
Ulf




Bewertung: 165 Punkte bei 55 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: D-Link DGE-528T (Gigabit Ethernet Karte) unter Kernel 2.6 zum Laufen bringen
Stefan Günther, Montag, 15. August 2005 21:29:39
Ein/Ausklappen

Hallo Ulf,

wenn die Karten bei ifconfig nicht auftauchenm, dann sollte Dich dies erst einmal nicht daran hindern, einen Versuch zu unternehmen ihnen eine IP-Adresse zuzuweisen.
HaSt Du mein ifconfig-Anweisung einmal versucht? Was hielt der Rechner davon, gab es eine Fehlermeldung oder hat er den Befehl angenommen? Wenn er den Befehl angenommen hat, wurde die Karte anschließend mit ifconfig angezeigt?

Viel Erfolg,

Stefan


Bewertung: 213 Punkte bei 63 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: D-Link DGE-528T (Gigabit Ethernet Karte) unter Kernel 2.6 zum Laufen bringen
Ulf B., Dienstag, 16. August 2005 16:35:26
Ein/Ausklappen

Hi Stefan,

habe das Problem gelöst. Lag wohl irgendwie an der Konfiguration (oder im Kopf - aber sei's Drum). Habe die Karte ausgebaut, alle Treiber und Einstellungen rückgängig gemacht und noch einmal eingebaut. Danach hat SuSE 9.3 die Karte bei der Hardware Erkennung richtig erkannt (Modul r8169.ko ). Und was soll ich sagen sie Läuft.

Übrigens hat mir der Support innerhalb von nur 5 Tagen (finde ich wirklich schnell, von einigen habe ich nach über einem Monat nur ein Ticket). Anbei der Teil der eigentlichen Antwort aus der Email: mir folgendes geantwortet:

has been answerd as follows: Auf der Karte ist ein Realtek Chipsatz (RTL8169S-32) verbaut. Entsprechende Treiber können Sie sich von der Webseite www.realtek.com.tw herunterladen. We hope that this answers your question and that your request is now resolved. This information is also available through our Support Portal at http://service.dlink.biz Regards - your D-Link Support Team P.S. If you have further questions regarding this request, please reply to this eMail without modifying the subject text. Na wer sagt's denn? Aber es war eben fiel einfacher wie ich gedacht hatte.

Ciao
Ulf



[1] http://lug-vs.endlose-rekursion.de/index.php/Hardware



Bewertung: 142 Punkte bei 49 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Samsung VG-KBD1500 - Bluetooth-Tastatur mit Touchpad mit Xubuntu 16.04.2 LTS
Linux- & BSD-UserGroup im Weserbergland, 16.08.2017 19:16, 0 Antworten
Bin grad mit "meinem Latein am Ende" darum hier mal so in den Raum geworfen. Samsung VG-KBD1500 -...
Tails verbindet nicht mit WLan
Georg Vogel, 30.07.2017 15:06, 5 Antworten
Hallo zusammen! Habe mir von Linux Mint aus einen Tails USB-Stick erstellt. Läuft soweit gut,...
Genivi for Raspberry Pi 3
Sebastian Ortmanns, 28.07.2017 10:37, 1 Antworten
I try to build a Genivi Development Platform for Rasberry Pi 3. But I always get the failures bel...
Bash awk Verständnis-Frage
Josef Federl, 22.07.2017 17:46, 2 Antworten
#!/bin/bash # Skriptdateiname = test.sh spaltennummer=10 wert=zehner awk '{ $'$spaltennummer'...
Bash - verschachtelte Variablenersetzung, das geht doch eleganter als meine Lösung?
Josef Federl, 18.07.2017 20:24, 3 Antworten
#!/bin/bash #Ziel des Skriptes wird sein die ID zu extrahieren hier nur als Consolentest: root@...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Internet Geschwindigkeit
Udo Teichmann, 19.08.2017 15:49
Am Samstag, den 05.08.2017, 18:20 +0200 schrieb Udo Teichmann: Liebe fleißige Helfer Vielen Dank für den Ti...
[EasyLinux-Ubuntu] Notebook wacht nicht mehr auf
Gerhard Blaschke, 19.08.2017 15:04
Hallo Liste, habe hier ein Notebook Acer Extensa 5630 mit Wheezy. Testweise habe ich es in den Ruhezustand...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Uwe Herrmuth, 18.08.2017 08:52
Hallo Volker, Volker schrieb am 18.08.2017 um 07:33: > volker@volker-Aspire-E5-575:~$ echo $PWD &&am...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Volker Borst, 18.08.2017 07:33
Hallo Uwe, Am 16.08.2017 um 21:56 schrieb Uwe Herrmuth: > > Dann hab ich eine ganz gewagte Vermutu...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Uwe Herrmuth, 16.08.2017 21:56
Hallo Volker, Volker Borst schrieb am 16.08.2017 um 19:22: > > echo $PS1 > > ${debian_chr...