D-Link DGE-528T (Gigabit Ethernet Karte) unter Kernel 2.6 zum Laufen bringen

Ulf B. - Freitag, 12. August 2005 22:41:59 - 4 Antworten



Hallo allerseits,

habe leider ein HW-Problem. Trotz größter Sorgfalt (oberflächliche Recherche im Internet). Habe ich oben genannte Gigabit Ethernet Karte [1] bei einem Händler um die Ecke [2] gekauft (leider habe ich gegen meine Gewohnheit nicht im Internet bestellt). Nachdem ich die Karten (natürlich auch noch zwei) in meinem kleinen Heimserver eingebaut hatte, wurden diese zwar von YaST (SuSE 9.2 - mit allen YOU Patches - Kernel 2.6.8-24.17-default) sofort erkannt, ich konnte aber dennoch keine Verbindung aufbauen. Nach genauen Studium der Log Files konnte ich nichts erkennen (keine Einträge). Egal was ich unternommen habe in der
       ifconfig 
tauchte keine Ethernet Schnittstelle auf. Ich habe dann noch versucht die via Internetrecherche gefundenen Hinweise umzusetzen, und es gelang mir auch die Module
 r8169.ko 
oder
       ns83820.ko 
ohne Fehlermeldung zu laden, aber leider hat dieses keine Änderung bzw. Logausgabe verursacht.

Im Internet auf der deutschen D-Link Seite gibt es nur Treiber für MacOS und WinXX [3]. Auf der beiligenden CD gibt es zwar Sourcen für die Kernel 2.3 und 2.4, welche aber nicht unter 2.6 Compalierbar sind. Ich habe gestern (11.08.2005) zwar eine Mail an den Support [4] geschrieben, habe aber wenig Hoffnung auf eine sinnvolle Antwort.

Nun sitze ich da mit meinem kurzen Hemd, und weiß nicht mehr weiter. Mein Händler nimmt normalerweise keine geöffneten PC-Einsteckkarten zurück (er müßte diese ja dann Testen). Und ich habe keine WinXX PC's im Einsatz (100% WinXX freie Zohne - na gut auf dem Notebook is noch eine kleine WinXP Service Partition). Wer hat noch Tipps, weiß noch etwas anderes (z.B. ob noch SW für den Chipsatz (D-Link DLG10028) in Entwicklung ist).

PS: Die Karte hat für knappe 17 &eur; ein kleines Zusätlich beigelegtes Slotblech und ein 3 Poliges Kabel (ich nehme an für WOL (Wake On LAN)).

Ciao
Ulf

[1] http://www.d-link.de/?go=jN...8sAmu5j3cf/YEPAM7l1KPjKUgYuOs=
[2] http://www.hoerco.de
[3] http://www.d-link.de/?go=gN...vhLPG3yV3oUo9/hK4uP54hMKZj6T8p
[4] mailto:support@dlink.de

Antworten
Re: D-Link DGE-528T (Gigabit Ethernet Karte) unter Kernel 2.6 zum Laufen bringen
Stefan Günther, Samstag, 13. August 2005 13:11:20
Ein/Ausklappen

Hi,

fangen wir einmal mit den naheliegenden Dingen an:
Was bekommst Du als Antwort, wenn Du den folgenden Befehl eingibst:

ifconfig eth0 192.168.0.1

Wenn Dein Rechner die Module lädt, dann hat er die Hardware ja auch gefunden, dann müßtest Du der Karte auch eine IP zuweisen können. Falls nicht, dann erhälst Du vielleicht eine Fehlermeldung, die Dir/uns weiterhilft.

Viel Erfolg,

Stefan


Bewertung: 186 Punkte bei 47 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: D-Link DGE-528T (Gigabit Ethernet Karte) unter Kernel 2.6 zum Laufen bringen
Ulf B., Samstag, 13. August 2005 17:23:31
Ein/Ausklappen

Hallo Stefan,

wie ich oben schon geschrieben habe, taucht die Netzwerkkarte schon gar nicht unter ifconfig auf (nur die anderen Schnittstellen werden angezeigt wie z.B. lo und irda0 ). Auch in den LOG-Dateien gibt es nicht eine Zeile die etwas damit zu tun hat (keine Fehlermeldung oder sonst einen verwertbaren Eintrag).

Ciao
Ulf




Bewertung: 162 Punkte bei 53 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: D-Link DGE-528T (Gigabit Ethernet Karte) unter Kernel 2.6 zum Laufen bringen
Stefan Günther, Montag, 15. August 2005 21:29:39
Ein/Ausklappen

Hallo Ulf,

wenn die Karten bei ifconfig nicht auftauchenm, dann sollte Dich dies erst einmal nicht daran hindern, einen Versuch zu unternehmen ihnen eine IP-Adresse zuzuweisen.
HaSt Du mein ifconfig-Anweisung einmal versucht? Was hielt der Rechner davon, gab es eine Fehlermeldung oder hat er den Befehl angenommen? Wenn er den Befehl angenommen hat, wurde die Karte anschließend mit ifconfig angezeigt?

Viel Erfolg,

Stefan


Bewertung: 219 Punkte bei 58 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: D-Link DGE-528T (Gigabit Ethernet Karte) unter Kernel 2.6 zum Laufen bringen
Ulf B., Dienstag, 16. August 2005 16:35:26
Ein/Ausklappen

Hi Stefan,

habe das Problem gelöst. Lag wohl irgendwie an der Konfiguration (oder im Kopf - aber sei's Drum). Habe die Karte ausgebaut, alle Treiber und Einstellungen rückgängig gemacht und noch einmal eingebaut. Danach hat SuSE 9.3 die Karte bei der Hardware Erkennung richtig erkannt (Modul r8169.ko ). Und was soll ich sagen sie Läuft.

Übrigens hat mir der Support innerhalb von nur 5 Tagen (finde ich wirklich schnell, von einigen habe ich nach über einem Monat nur ein Ticket). Anbei der Teil der eigentlichen Antwort aus der Email: mir folgendes geantwortet:

has been answerd as follows: Auf der Karte ist ein Realtek Chipsatz (RTL8169S-32) verbaut. Entsprechende Treiber können Sie sich von der Webseite www.realtek.com.tw herunterladen. We hope that this answers your question and that your request is now resolved. This information is also available through our Support Portal at http://service.dlink.biz Regards - your D-Link Support Team P.S. If you have further questions regarding this request, please reply to this eMail without modifying the subject text. Na wer sagt's denn? Aber es war eben fiel einfacher wie ich gedacht hatte.

Ciao
Ulf



[1] http://lug-vs.endlose-rekursion.de/index.php/Hardware



Bewertung: 145 Punkte bei 44 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Anfänger Frage
Klaus Müller, 24.05.2017 14:25, 1 Antworten
Hallo erstmal. Habe von linux nicht so viel erfahrung müsste aber mal ne doofe frage stellen. A...
Knoppix-Live-CD (8.0 LU-Edition) im Uefiboot?
Thomas Weiss, 26.04.2017 20:38, 2 Antworten
Hallo, Da mein Rechner unter Windows 8.1/64Bit ein Soundproblem hat und ich abklären wollte, o...
Grub2 reparieren
Brain Stuff, 26.04.2017 02:04, 5 Antworten
Ein Windows Update hat mir Grub zerschossen ... der Computer startet nicht mehr mit Grub, sondern...
Linux open suse 2,8
Wolfgang Gerhard Zeidler, 18.04.2017 09:17, 2 Antworten
Hallo.bitte um Hilfe bei. Code fuer den Rescue-login open suse2.8 Mfg Yvo
grep und sed , gleicher Regulärer Ausdruck , sed mit falschem Ergebnis.
Josef Federl, 15.04.2017 00:23, 1 Antworten
Daten: dlfkjgkldgjldfgl55.55klsdjfl jfjfjfj8.22fdgddfg {"id":"1","name":"Phase L1","unit":"A",...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] [OT] Krass unterschiedliche Prozessorleistung
Uwe Herrmuth, 25.05.2017 12:28
Hallo Michael, Michael schrieb am 25.05.2017 um 11:17: mit ungültiger Signatur. Hast Du vielleicht auf De...
Re: [EasyLinux-Ubuntu] Krass unterschiedliche Prozessorleistung
"Michael R. Moschner", 25.05.2017 11:17
Am Dienstag, 16. Mai 2017, 23:00:16 schrieb Alfred Zahlten: Hallo Alfred und Steffen > > Ist der Proz...
Re: [EasyLinux-Ubuntu] Debian XFCE Energieverwaltung
Heiko Ißleib, 25.05.2017 00:40
Hallo. Tatsächlich Google ich Geräte nach Linuxtauglichkeit.Oder kaufe Rechner,die auch ohne Windows angeb...
Re: [EasyLinux-Ubuntu] Debian XFCE Energieverwaltung
flecralf, 25.05.2017 00:17
Am 24.05.2017 um 18:57 schrieb Alexander McLean: > Am Dienstag, den 23.05.2017, 00:01 +0200 schrieb flecra...
Re: [EasyLinux-Ubuntu] Debian XFCE Energieverwaltung
Alexander McLean, 24.05.2017 18:57
Am Dienstag, den 23.05.2017, 00:01 +0200 schrieb flecralf: > > Ist alles keine gute Werbung für Linu...