Auflösung XServer bei Debian 3.1 auf 1024x768 einstellen

Autor

Sonntag, 09. Oktober 2005 09:41:15

Habe als Anfänger (und nach langer Linux-Abstinenz) die geführte Installation von Debian 3.1 auf einem eigenen Rechner durchgeführt.
Habe die Installation erfolgreich abgeschlossen, aber der XServer und damit alle GUI laufen nur in 800x600 Anzeige.
Sowohl meine ATI-AGPGrafikkarte als auch der Sony-Multiscan-Monitor können aber mindestens 1024x768 in guter Bildwiederholung. Sowohl unter Windoofs als auch unter einer vor langer Zeit von mir durchgeführten SuSE-Installation lief diese Hardware-Konfiguration auch schon im 1024x768-Modus.
Bei der Konfiguration des X-Servers in der Installationsroutine habe ich es mit Standard-, Medium- und Advanced-Modus versucht. Brav alle geforderten Daten eingegeben sowohl mit vga- und ati-Treiber die Installation durchgeführt.
Wie kann ich die Auflösung für den XServer nach Abschluss der Installation verändern?

Olaf Böttcher

6 Antworten


Antworten
Re: Auflösung XServer bei Debian 3.1 auf 1024x768 einstellen
Anoopy , Montag, 10. Oktober 2005 08:55:15
Ein/Ausklappen

Hallo Olaf,

versuch einmal "dpkg-reconfigure xserver-xfree86". Bei den Angaben zum Bildschirm als einziges die Auflösung 1024x768 auswählen. Das sollte Dein Problem lösen.

Damit Du das nicht auf der Konsole machen musst, kannst Du über aptitude oder mittels "apt-get -i gkdebconf" ein grafisches Werkzeug installieren, welche sämtliche über "dpkg-reconfigure" einstellbaren Variablen zusammenfasst.

Freundliche Grüsse

Snoopy

Kleiner Hinweis: Schau mal unter [1], im Speziellen unter [2]

[1] http://www.debiananwenderhandbuch.de/
[2] http://www.debiananwenderhandbuch.de/dpkg-reconfigure.html



Bewertung: 97 Punkte bei 25 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Auflösung XServer bei Debian 3.1 auf 1024x768 einstellen
Ugglan , Montag, 10. Oktober 2005 17:58:23
Ein/Ausklappen

> versuch einmal "dpkg-reconfigure xserver-xfree86". Bei den Angaben zum
> Bildschirm als einziges die Auflösung 1024x768 auswählen. Das sollte Dein
> Problem lösen.

Das hat bei mir geholfen, allerdings muß man den Bildschirm im "Advanced" Modus konfigurieren, sonst kriegt man wieder nur 800x600 und max. 75Hz hin.
Du kannst ruhig mehrere Auflösungen angeben, wenn Du Gnome verwendest. Nachdem Du den X-Server konfiguriert hast, bietet Dir der Bildschirmdialog auch höhere Auflösungen und Frequenzen an. Ob das in KDE ähnlich ist, kann ich nicht sagen.

Eine Falle lauert im Keyboard-Dialog (in der Shell): Nachdem ich als Typ "pc102" eingegeben hatte und im Anschluß die Optionen (deadkeys, Capslock-Verhalten etc.) einstellen sollte, bekom ich wieder nur den Dialog für den Keyboardtyp, den ich ja schon beantwortet hatte. Etwas verwirrt gab ich nochmal "pc102" ein, was prompt zu einer unbraucbaren Tastatur (deutsches Layout, aber ohne Drittbelegung) unter Gnome führte. Nachdem ich die X-Konfiguration ein zweites Mal durchkurbelte, gab ich stur beim zweiten Erscheinen des Keyboardtyp-Dialogs statt "PC102" meine Optionen ein, und siehe da, es funktioniert :-/ .

Viel Erfolg,

Ugglan

PS: /etc/X11/XF86config[-4] vorher sichern!


Bewertung: 199 Punkte bei 29 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Auflösung XServer bei Debian 3.1 auf 1024x768 einstellen
Olaf Böttcher, Montag, 10. Oktober 2005 20:43:11
Ein/Ausklappen

Hallo Snoopy, hallo Ugglan,

ich habe das Programm "dpkg-reconfigure xserver-xfree86" laufen gelassen und
den nötigen Eintrag zur Auflösung vorgenommen.
Neustart des XServers und es läuft!
Problem gelöst!

Vielen Dank

Und als Newbie habe ich mir als nächstes mal die Internetadresse hinter die
Ohren geschrieben . . .

Grüße

Olaf

ps Tastatur, Maus etc. machen bei mir keine Probleme.


Bewertung: 131 Punkte bei 24 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Auflösung XServer bei Debian 3.1 auf 1024x768 einstellen
Olaf Böttcher, Montag, 10. Oktober 2005 20:40:40
Ein/Ausklappen

Hallo Snoopy, hallo Ugglan,

ich habe das Programm "dpkg-reconfigure xserver-xfree86" laufen gelassen und
den nötigen Eintrag zur Auflösung vorgenommen.
Neustart des XServers und es läuft!
Problem gelöst!

Vielen Dank

Und als Newbie habe ich mir als nächstes mal die Internetadresse hinter die
Ohren geschrieben . . .

Grüße

Olaf


Bewertung: 89 Punkte bei 30 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Auflösung XServer bei Debian 3.1 auf 1024x768 einstellen
Michael Busch, Sonntag, 09. Oktober 2005 11:32:44
Ein/Ausklappen

Hallo,

hast Du schon versucht die Auflösung bei Deinen eigenen Eistellungen (Präferenzen) zu ändern?
Sonst einfach als root die XFree86-Configdatei unter /etc/X11/ im Texteditor öffnen und die entsprechende Auflösung unter der Section "Screen" nachtragen.
Bitte NUR die Auflösung ergänzen!

Beispiel:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Entsprechend Deine Auflösung eintragen.

Außerdem kannst Du unter Section "Monitor" noch Deine Monitor-Daten nachtragen: (auch hier NUR die Daten Deines Monitors evtl. anpassen!)

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unknown monitor"
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Anschließend den X-Server neu starten. Dann solltest Du auch unter Präferenzen Deine Auflösung und Wiederholungsrate aussuchen können.

Gruß, michi


Bewertung: 165 Punkte bei 31 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Auflösung XServer bei Debian 3.1 auf 1024x768 einstellen
Olaf Böttcher, Montag, 10. Oktober 2005 20:34:50
Ein/Ausklappen

Hallo Michi,

in der Konfigurationsdatei fehlt tatsächlich die Angabe "1024x768"
Erster Hinweis zur Lösung!
Danke


Bewertung: 190 Punkte bei 23 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Tropentraum
    Mit Dreamlinux erhalten auch schwachbrüstige Rechner einen 3D-Desktop und eine modern wirkende Oberfläche, ohne dabei auf Funktionalität verzichten zu müssen.
  • Doppelbilder
    Mit XRandR steuern Sie Beamer und Multihead-Installationen einfacher und intuitiver als mit TwinView, MergedFB oder Xinerama.
  • X auf Reisen
    Wer mit seinem Notebook häufig verschiedene Displays in unterschiedlichen Anordnungen nutzt, weiß ein einfaches Umschalten dazwischen zu schätzen.
  • Das X-Window-System
    Was steckt eigentlich hinter dem ominösen X-Window-System? Wozu braucht man es, wenn man doch eigentlich nur mit KDE oder GNOME arbeiten will?
  • Knoppix und Ubuntu
    Ubuntu Linux und Knoppix basieren auf Debian – wir verraten Tricks und Kniffe, welche die Arbeit auf diesen Distributionen angenehmer machen.

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 0 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Nach Ubdates alles weg ...
Maria Hänel, 15.11.2014 17:23, 4 Antworten
Ich brauche dringen eure Hilfe . Ich habe am wochenende ein paar Ubdates durch mein Notebook von...
Brother Drucker MFC-7420
helmut berger, 11.11.2014 12:40, 1 Antworten
Hallo, ich habe einen Drucker, brother MFC-7420. Bin erst seit einigen Tagen ubuntu 14.04-Nutzer...
Treiber für Drucker brother MFC-7420
helmut berger, 10.11.2014 16:05, 2 Antworten
Hallo, ich habe einen Drucker, brother MFC-7420. Bin erst seit einigen Tagen ubuntu12.14-Nutzer u...
Can't find X includes.
Roland Welcker, 05.11.2014 14:39, 1 Antworten
Diese Meldung erhalte ich beim Versuch, kdar zu installieren. OpenSuse 12.3. Gruß an alle Linuxf...
DVDs über einen geeigneten DLNA-Server schauen
GoaSkin , 03.11.2014 17:19, 0 Antworten
Mein DVD-Player wird fast nie genutzt. Darum möchte ich ihn eigentlich gerne abbauen. Dennoch wür...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] PC mit LinuxMint14, cinnamon, Gnome
Thomas Lueck, 28.11.2014 11:57
Am Montag, den 24.11.2014, 09:33 +0100 schrieb Gerhard Blaschke: > Das ist ein Problem der Distributionsau...
Re: [EasyLinux-Ubuntu] [OT:Linux-Verbreitung] was:PC mit LinuxMint14, cinnamon, Gnome
Thomas Lueck, 28.11.2014 11:53
Am Freitag, den 28.11.2014, 09:35 +0100 schrieb Gerhard Blaschke: > Ich möchte aber darüber jetzt keinen f...
Re: [EasyLinux-Ubuntu] PC mit LinuxMint14, cinnamon, Gnome
Gerhard Blaschke, 28.11.2014 11:47
Am 25.11.2014 um 23:43 schrieb Alfred Zahlten: > Am 25.11.2014 um 03:03 schrieb Heiko Ißleib: >> A...
Re: [EasyLinux-Ubuntu] PC mit LinuxMint14, cinnamon, Gnome
Thomas Lueck, 28.11.2014 11:41
Am Dienstag, den 25.11.2014, 23:43 +0100 schrieb Alfred Zahlten: > Das Problem dabei ist wohl das /var ode...
Re: [EasyLinux-Ubuntu] [OT:Linux-Verbreitung] was:PC mit LinuxMint14, cinnamon, Gnome
Gerhard Blaschke, 28.11.2014 09:35
Am 28.11.2014 um 06:10 schrieb Heiko Ißleib: > Am Dienstag, 25. November 2014, 23:43:57 schrieb Alfred Zah...