Apache2, Options -Indexes geht nicht

no no - Samstag, 12. Mai 2012 19:01:28 - 8 Antworten

Habe in apache2.conf folgendes stehen:

<Directory /var/www>
Options -Indexes
</Directory>

Bei Abwesenheit von index.html wird aber leider doch ein Inhaltsverzeichnis angezeigt???

Bei Apache 2.2.20, Ubuntu 11.10

Danke, Klaus

Antworten
AllowOverride hat keinen Effekt
no no, Sonntag, 13. Mai 2012 19:22:30
Ein/Ausklappen

hallo Holger,
danke für die Antwort.

Ich dachte AllowOverride braucht man nur in .htaccess Dateien.
Hab's trotzdem mal in die apache2.conf reingesetzt.
Da sieht es jetzt so aus:

<Directory /var/www>
AllowOverride All
Options -Indexes
</Directory>

Hat aber keinen Effekt.

Gruss, Klaus




Bewertung: 233 Punkte bei 24 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: AllowOverride hat keinen Effekt
Holger (unangemeldet), Sonntag, 13. Mai 2012 21:21:18
Ein/Ausklappen

Du hast Apache danach auch neu gestartet? ;-)

Bei mir sieht das so aus:

AllowOverride FileInfo AuthConfig Limit Indexes
Options MultiViews -Indexes SymLinksIfOwnerMatch IncludesNoExec

Und es funktioniert. Ich nutze für die Konfiguration webmin.

http://www.webmin.com/download.html


Bewertung: 189 Punkte bei 35 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: AllowOverride hat keinen Effekt auch mit deiner config
no no, Montag, 14. Mai 2012 17:21:00
Ein/Ausklappen

Ich versteh's nicht!
Ich hab' deine config in die apache2.conf reingenommen.
Das siehst so aus:

<Directory /var/www>
AllowOverride FileInfo AuthConfig Limit Indexes
Options MultiViews -Indexes SymLinksIfOwnerMatch IncludesNoExec
</Directory>

Bei Apache reload wird nur folgendes angezeigt:

sudo /etc/init.d/apache2 force-reload
* Reloading web server config apache2
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

Bei Aufruf von localhost erscheint wieder das directory listing???

Danke und Gruss, Klaus


Bewertung: 104 Punkte bei 75 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: AllowOverride hat keinen Effekt auch mit deiner config
Holger (unangemeldet), Dienstag, 15. Mai 2012 01:09:42
Ein/Ausklappen

Muss es nicht 127.0.0.1 heißen? Bei Fehler wird die Konfiguration nicht aktualisiert.

Versuch es mal so:

<Directory "/var/www"> ->in Anführungszeichen!
Options None
order deny,allow
allow from all
</Directory>

Wird Indexes nicht aufgeführt, ist es ausgeschaltet. Mit "-" wird es deaktiviert.


Bewertung: 202 Punkte bei 23 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: AllowOverride hat keinen Effekt auch neuer config
no no, Dienstag, 15. Mai 2012 16:37:15
Ein/Ausklappen

Die Fehlermeldung bekomm' ich mit folgender directive in apche2.conf weg.

ServerName lokalKW

Da das einen Effekt hat geh' ich davon aus, dass die config aktualisiert wird.

BTW: Die 127.0.1.1. kommt bei mir aus /ect/hosts:

/etc/hosts
127.0.0.1 localhost
127.0.1.1 BullmannKW
...

Leider haben die neue Directory section und die Anführungszeichen keinen Effekt.
Es wird wieder das directory listing angezeigt.

Ich bin bald am Verzweifeln.

Danke, Klaus



Bewertung: 188 Punkte bei 25 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: AllowOverride hat keinen Effekt auch neuer config
Holger (unangemeldet), Dienstag, 15. Mai 2012 19:25:42
Ein/Ausklappen

Merkwürdig. Was passiert denn, wenn Du im Verzeichnis eine .htaccess-Datei mit options -indexes anlegst?


Bewertung: 218 Punkte bei 26 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: mit .htaccess geht's auch nicht
no no, Donnerstag, 17. Mai 2012 17:29:53
Ein/Ausklappen

Tja, da wird ein directory listing angezeigt.

Danke und Gruss, Klaus


Bewertung: 113 Punkte bei 72 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Apache2, Options -Indexes geht nicht
Holger (unangemeldet), Sonntag, 13. Mai 2012 00:01:49
Ein/Ausklappen

Tip: AllowOverride


Bewertung: 211 Punkte bei 29 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Web-Server Apache 2
    Das Herzstück eines typischen Internet-Servers bildet ein Programm, das WWW-Seiten anbietet. Weltweit am häufigsten genutztes Exemplar dieser Gattung ist der Apache-Web-Server, dessen Entwickler kürzlich die Version 2 zur allgemeinen Verwendung freigaben.
  • Schlanke Apache-Alternative Nginx
    Schnell, ressourcenschonend und leicht zu konfigurieren – dank dieser Attribute eignet sich der Webserver Nginx nicht nur für High-Traffic-Websites.
  • Live Streaming mit Flumotion
    Wollen Sie im großen Stil Multimedia-Inhalte unter das Internetvolk bringen, hilft Ihnen die Streaming Media Software Flumotion.
  • MP3-Jukebox mit Web-Frontend
    Eine große MP3-Sammlung auf dem Server ist nicht mehr ungewöhnlich. Damit wird der Computer zur elektronischen Jukebox, die Sie mit der Web-Applikation Otto bequem fernsteuern.
  • Apache HTTP-Server 2.2.20 macht DoS-Lücke dicht

    Mit Version 2.2.20 des populären Apache HTTP-Servers schließen die Entwickler eine Lücke, die zum Denial-of-Service genutzt werden konnte.

Aktuelle Fragen

Samsung VG-KBD1500 - Bluetooth-Tastatur mit Touchpad mit Xubuntu 16.04.2 LTS
Linux- & BSD-UserGroup im Weserbergland, 16.08.2017 19:16, 0 Antworten
Bin grad mit "meinem Latein am Ende" darum hier mal so in den Raum geworfen. Samsung VG-KBD1500 -...
Tails verbindet nicht mit WLan
Georg Vogel, 30.07.2017 15:06, 5 Antworten
Hallo zusammen! Habe mir von Linux Mint aus einen Tails USB-Stick erstellt. Läuft soweit gut,...
Genivi for Raspberry Pi 3
Sebastian Ortmanns, 28.07.2017 10:37, 1 Antworten
I try to build a Genivi Development Platform for Rasberry Pi 3. But I always get the failures bel...
Bash awk Verständnis-Frage
Josef Federl, 22.07.2017 17:46, 2 Antworten
#!/bin/bash # Skriptdateiname = test.sh spaltennummer=10 wert=zehner awk '{ $'$spaltennummer'...
Bash - verschachtelte Variablenersetzung, das geht doch eleganter als meine Lösung?
Josef Federl, 18.07.2017 20:24, 3 Antworten
#!/bin/bash #Ziel des Skriptes wird sein die ID zu extrahieren hier nur als Consolentest: root@...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Uwe Herrmuth, 18.08.2017 09:00
Hallo Volker, Volker schrieb am 18.08.2017 um 07:33: > volker@volker-Aspire-E5-575:~$ echo $PWD &&am...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Volker Borst, 18.08.2017 07:33
Hallo Uwe, Am 16.08.2017 um 21:56 schrieb Uwe Herrmuth: > > Dann hab ich eine ganz gewagte Vermutu...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Uwe Herrmuth, 16.08.2017 21:56
Hallo Volker, Volker Borst schrieb am 16.08.2017 um 19:22: > > echo $PS1 > > ${debian_chr...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Volker Borst, 16.08.2017 19:22
Hallo Uwe, > echo $PS1 ${debian_chroot:+($debian_chroot)}\u@\h:\w\$ Einen neuen Benutzer habe ich jet...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Uwe Herrmuth, 16.08.2017 07:58
Hallo Volker, Volker schrieb am 12.08.2017 um 12:11: > Nach dem Aufrufen von 16.04 habe ich in der bash...