Als Root falsche Auflösung unter Gnome

Autor

Dienstag, 01. Juli 2008 12:46:25

Hallo Zusammen,

Ich verwende das derzeit aktuelle Red Hat 2.16.0(stand 28.06.2008), Monitor und Grafikkarte werden korrekt erkannt.

Folgendes Problem habe ich damit:

Wenn ich als normaler User eingeloggt bin, kann ich eine maximale Auflösung von 1024x768 einstellen, obwohl Monitor und Grafikkarte mehr können.
Habe das bereits mit einem anderen Monitor ausprobiert, der 1920x1200 kann, allerdings das selbe Problem.

In meine xorg.conf habe ich im Moment eine Auflösung von 1280x1024 eingestellt, die under KDE als User und als Root und unter Gnome als User übernommen wird.

Sobald ich mich allerdings als Root unter Gnome anmelde stellt er automatisch auf 1024x768 um, also die Auflösung die er scheinbar als höchstmögliche erkennt.

Nun frage ich mich, ob eventuell beim Anmelden die Monitor Informationen abgefragt werden, und diese falsch sind.

Vielen Dank im Vorraus und Grüße,
Felix

FelixL

4 Antworten


Antworten
Re: Als Root falsche Auflösung unter Gnome
Joachim Janssen, Montag, 07. Juli 2008 15:51:28
Ein/Ausklappen

Es ist nicht sinnvoll sich mit dem Rootbenutzer über X anzumelden. Es gibt auch eigentlich keinen Grund dafür. Wozu benötigt das ? es reicht su oder sudo um Einstellungen am System vorzunehmen.

Gruß Joachim


Bewertung: 113 Punkte bei 41 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Als Root falsche Auflösung unter Gnome
FelixL , Montag, 14. Juli 2008 09:54:23
Ein/Ausklappen

Vielen Dank für eure beiden Antworten, leider ist weder mein Kabel zu lang, noch hilft mir die Aussage das ich mich nicht als root anmelden sollte :-).

Das Problem besteht nunmal, und ich möchte herrausfinden warum es bei KDE funktioniert, und bei Gnome nicht.

Grüße,
Felix



Bewertung: 156 Punkte bei 41 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Als Root falsche Auflösung unter Gnome
Dieter Drewanz, Dienstag, 15. Juli 2008 17:40:39
Ein/Ausklappen

Es ist nur eine Vermutung, aber vielleicht hilft das weiter. Es gibt bei mir auch eine Möglichkeit, wie es bei KDE nicht geht. Wenn ich beim Start entscheide, ob ich mich als user oder root anmelde, dann hat root die gleiche Auflösung, wie der user und auch die 3D Unterstützung (mit tuxracer, glxinfo und glxgears getestet). Öffne ich einen weiteren anderen user mit eigener KDE Oberfläche (d.h. ich kann mit str+alt+f5...f8 nicht nur zu verschiedenen Konsolen, sondern auch zu verschiedenen KDE/X11 Oberflächen wechseln; d.h. ein weiterer user zugleich - richtig multi-tasking - das geht auch mit dem root statt user) dann hat der zweite user keine 3D Unterstützung (getestet wie vorher beschrieben) und nicht alle Auflösungen.
Oft sind die Sonderauflösungen (d.h. nicht 640x480, 800x600, und 1024x768) und die 3D Beschleunigung bei den Treibern nur dem ersten X11 (screen(0,0)) zugeordnet bzw. benutzbar. Wenn ich nur einen öffne, dieser aber (0,1) ist, dann fehlt wie besagt die 3D Unterstützung und ggf. einige Auflösungsmodi.
Möglich wäre, dass Gnome den root nie als (0,0), sondern (x,y) öffnet. Das steht auch in irgendeiner Konfigurationsdatei. Ich weiß aber nicht in welcher.
(was ich mit screen(0,0) bezeichnet habe, müßte Display:0.0 heißen. Der untere Link beschreibt wie man ein Meldungsfenster öffnet. Das ging bei mir mit KDE Suse 9.3+10.1 und Ubuntu 6.06 mit Gnome. Wenn bei root 0.0 nicht geht aber 0.1 oder 1.1, oder 1.0 ... ein Meldungsfenster sich öffnen läßt, dann kann der hier geschilderte Fall zutreffen.)

[1] https://www.linux-community.de/Neues/story?storyid=23665



Bewertung: 199 Punkte bei 39 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Als Root falsche Auflösung unter Gnome
Andreas M., Dienstag, 01. Juli 2008 21:09:12
Ein/Ausklappen

Hallo,

ich hatte das Problem unter Ubuntu. Der Grund war ein zu langes VGA-Kabel, wodurch vermutl. der Monitor nicht richtig erkannt wurde. Selbst die Monitor.inf - Datei hatte nur temporär geholfen. Nach jedem Neustart war alles wieder vergessen. Nachdem ich die VGA-Verlängerung entfert hatte, funktionierte alles.

Gruß
Andreas


Bewertung: 193 Punkte bei 40 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Stellenanzeigen

System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)


Senior-System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Fernwartung oder wartung im haus
heide marie voigt, 29.06.2015 10:37, 2 Antworten
gerne hätte ich jemanden in Bremen nord, der mir weiter hilft - angebote bitte mit preis HMVoigt
Druckeranschluss DCP-195C
heide marie voigt, 29.06.2015 10:35, 1 Antworten
installiert ist linux ubuntu 15.04 offenbar auch der treiber für den Drucker DCP-195C. Die Konta...
keine arbeitsleiste beim einloggen
heide marie voigt, 27.06.2015 13:31, 0 Antworten
seit der neu-installierung von linux ubuntu 15.04 erscheint die arbeitsleiste rechts oben erst na...
raid platte an linux mint 17.1
andreas schug, 23.06.2015 19:44, 0 Antworten
folgende thematik NAS Iomega Storage Center wird auf einmal nicht mehr im netzwerk erkannt .....
SUSE 13.2 - Probleme mit kmail
kris kelvin, 03.06.2015 13:26, 2 Antworten
Hallo, nach dem Umstieg auf 13.1 hatte ich das Problem, daß kmail extrem langsam reagierte. Nun...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] [erledigt]_Opwera_öffnet_Seite_nicht
Hartmut Haase, 02.07.2015 11:01
Hallo Heiko, > Ist denn icedtea-7-plugin installiert und openjdk-7-jre oder das Java > von Oracle dir...
Re: [EasyLinux-Ubuntu] [erledigt]_Opwera_öffnet_Seite_nicht
Heiko Ißleib, 02.07.2015 10:21
Hallo Hartmut. Ist denn icedtea-7-plugin installiert und openjdk-7-jre oder das Java von Oracle direkt,was...
Re: [EasyLinux-Ubuntu] [erledigt]_Opwera_öffnet_Seite_nicht
Hartmut Haase, 02.07.2015 09:46
Hallo Heiko, danke für die Hinweise, aber ich komme mit dem Krempel nicht klar. Und wenn man so viele Klim...
Re: [EasyLinux-Ubuntu] externer Blue-ray Brenner
Heiko, 02.07.2015 06:32
Am Mittwoch, 1. Juli 2015, 22:52:34 schrieb Joachim Puttkammer: Hallo Joachim. > > möchte mir so e...
Re: [EasyLinux-Ubuntu] Text von Linux nach Win
Matthias Müller, 01.07.2015 22:59
Hallo * Am Mittwoch, 1. Juli 2015 schrieb Gerd Ewald: > Hallo Matthias, > > Du hattest am Tue...