Als Root falsche Auflösung unter Gnome

Autor

Dienstag, 01. Juli 2008 12:46:25

Hallo Zusammen,

Ich verwende das derzeit aktuelle Red Hat 2.16.0(stand 28.06.2008), Monitor und Grafikkarte werden korrekt erkannt.

Folgendes Problem habe ich damit:

Wenn ich als normaler User eingeloggt bin, kann ich eine maximale Auflösung von 1024x768 einstellen, obwohl Monitor und Grafikkarte mehr können.
Habe das bereits mit einem anderen Monitor ausprobiert, der 1920x1200 kann, allerdings das selbe Problem.

In meine xorg.conf habe ich im Moment eine Auflösung von 1280x1024 eingestellt, die under KDE als User und als Root und unter Gnome als User übernommen wird.

Sobald ich mich allerdings als Root unter Gnome anmelde stellt er automatisch auf 1024x768 um, also die Auflösung die er scheinbar als höchstmögliche erkennt.

Nun frage ich mich, ob eventuell beim Anmelden die Monitor Informationen abgefragt werden, und diese falsch sind.

Vielen Dank im Vorraus und Grüße,
Felix

FelixL

4 Antworten


Antworten
Re: Als Root falsche Auflösung unter Gnome
Joachim Janssen, Montag, 07. Juli 2008 15:51:28
Ein/Ausklappen

Es ist nicht sinnvoll sich mit dem Rootbenutzer über X anzumelden. Es gibt auch eigentlich keinen Grund dafür. Wozu benötigt das ? es reicht su oder sudo um Einstellungen am System vorzunehmen.

Gruß Joachim


Bewertung: 113 Punkte bei 41 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Als Root falsche Auflösung unter Gnome
FelixL , Montag, 14. Juli 2008 09:54:23
Ein/Ausklappen

Vielen Dank für eure beiden Antworten, leider ist weder mein Kabel zu lang, noch hilft mir die Aussage das ich mich nicht als root anmelden sollte :-).

Das Problem besteht nunmal, und ich möchte herrausfinden warum es bei KDE funktioniert, und bei Gnome nicht.

Grüße,
Felix



Bewertung: 156 Punkte bei 41 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Als Root falsche Auflösung unter Gnome
Dieter Drewanz, Dienstag, 15. Juli 2008 17:40:39
Ein/Ausklappen

Es ist nur eine Vermutung, aber vielleicht hilft das weiter. Es gibt bei mir auch eine Möglichkeit, wie es bei KDE nicht geht. Wenn ich beim Start entscheide, ob ich mich als user oder root anmelde, dann hat root die gleiche Auflösung, wie der user und auch die 3D Unterstützung (mit tuxracer, glxinfo und glxgears getestet). Öffne ich einen weiteren anderen user mit eigener KDE Oberfläche (d.h. ich kann mit str+alt+f5...f8 nicht nur zu verschiedenen Konsolen, sondern auch zu verschiedenen KDE/X11 Oberflächen wechseln; d.h. ein weiterer user zugleich - richtig multi-tasking - das geht auch mit dem root statt user) dann hat der zweite user keine 3D Unterstützung (getestet wie vorher beschrieben) und nicht alle Auflösungen.
Oft sind die Sonderauflösungen (d.h. nicht 640x480, 800x600, und 1024x768) und die 3D Beschleunigung bei den Treibern nur dem ersten X11 (screen(0,0)) zugeordnet bzw. benutzbar. Wenn ich nur einen öffne, dieser aber (0,1) ist, dann fehlt wie besagt die 3D Unterstützung und ggf. einige Auflösungsmodi.
Möglich wäre, dass Gnome den root nie als (0,0), sondern (x,y) öffnet. Das steht auch in irgendeiner Konfigurationsdatei. Ich weiß aber nicht in welcher.
(was ich mit screen(0,0) bezeichnet habe, müßte Display:0.0 heißen. Der untere Link beschreibt wie man ein Meldungsfenster öffnet. Das ging bei mir mit KDE Suse 9.3+10.1 und Ubuntu 6.06 mit Gnome. Wenn bei root 0.0 nicht geht aber 0.1 oder 1.1, oder 1.0 ... ein Meldungsfenster sich öffnen läßt, dann kann der hier geschilderte Fall zutreffen.)

[1] https://www.linux-community.de/Neues/story?storyid=23665



Bewertung: 199 Punkte bei 39 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Als Root falsche Auflösung unter Gnome
Andreas M., Dienstag, 01. Juli 2008 21:09:12
Ein/Ausklappen

Hallo,

ich hatte das Problem unter Ubuntu. Der Grund war ein zu langes VGA-Kabel, wodurch vermutl. der Monitor nicht richtig erkannt wurde. Selbst die Monitor.inf - Datei hatte nur temporär geholfen. Nach jedem Neustart war alles wieder vergessen. Nachdem ich die VGA-Verlängerung entfert hatte, funktionierte alles.

Gruß
Andreas


Bewertung: 193 Punkte bei 40 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Admin Probleme mit Q4os
Thomas Weiss, 30.03.2015 20:27, 6 Antworten
Hallo Leute, ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verl...
eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 1 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...
Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 6 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Claws Mail: Export von Adressen
Rainer, 25.04.2015 19:17
Hallo Jörg, Am Thu, 16 Apr 2015 14:14:12 +0200 schrieb Rainer : > > > > > > Abschlie...
Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Hartmut Haase, 23.04.2015 18:08
Hallo Rainer, mit meinem xubuntu 14.04 benutze ich simple scan 3.12.1 und hplip 3.15.4. Diese Version beko...
Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Rainer, 23.04.2015 12:05
Hallo Hartmut, Am Wed, 22 Apr 2015 10:10:51 +0200 schrieb Hartmut Haase : > > > Also ohne auc...
Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Hartmut Haase, 22.04.2015 10:10
Hallo Rainer, > Also ohne auch nur den Hauch einer Idee, was hier faul sein könnte, > bleibt es ein r...
Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Rainer, 21.04.2015 20:14
Hallo Hartmut, Am Tue, 21 Apr 2015 09:21:48 +0200 schrieb Hartmut Haase : > > HPLIP ist hier in Bet...