Ade, Internet. Trotz Verbindung mit Internet..

Baba Lussi - Montag, 06. April 2009 17:05:05 - 7 Antworten


Liebe Community

Das nennt sich das erste Mal, das hier oder in einer vergleichbaren Community üerhaupt Fuss gefasst wird. Mittlerweile hat Linux auch mir ans Bein gepisst blunk

Das Problem beginnt damit, dass mein Bruder seine Wochen im Militär absitzt. Nicht nur unschön für ihn, sondern auch unschön für mich, weil ebenjener Bruder die Linux-Fäden bei uns zuhause in der Hand hat. Probleme gibt es solange keine, wie Brüder in der Nähe sind, die die Materie im Griff haben. Da nun dieser einzige abwesend ist, macht sich Hilflosigkeit breit; seit der Rundumschlag gegen Gates erfolgt ist, können Probleme wie das folgende nicht mehr selbst gelöst werden:
(vorneweg gestellt: mein Linux-Wortschatz begrenzt sich auf gnome-terminal, aptitude upgrade, debian und kernel - verzeiht also unschön Ausgedrücktes..)

Im eigenen Besitz sind zum einen ein Laptop, zum anderen ein Netbook (eeepc); beide mit Linux ausgestattet. Internet gibts grundsätzlich wireless. Sorgenkind ist nun der Laptop. Debian, das sich dort darauf befindet (etch testing) funktioniert alles in allem. Vor kurzem nun habe ich laufende updates unterbrochen, und am nächsten Morgen wars dann so weit: Internet ging nicht mehr.
Zumindest auf dem Laptop, gleich, dass das wirelessnetz gefunden und angewählt werden kann, und sogar die Anzeige provoziert, dass man damit befunden sei. Wird aber Iceweasle oder Icedove gestartet, tut sich so gar nichts.
Via Systemwerkzeuge-> Netzwerkdiagnose habe ich auf Geheiss meines Bruder mal einen PING ruausgeschickt, Freund google konnte so gefunden werden (trotz streikendem Iceweasle).
Das Spiel im terminal (/etc/init.d/networking force-reload) hat nichts genutzt, ebensowenig der Versuch, einen alten Kernel beim Aufstarten auszuwählen um zu versuchen, dort die unterbrochenen updates nochmals durchzuziehen.

Die Ironie an der ganzen Sache ist, dass das Internet mit dem Netbook weiterhin tadellos läuft.

Tatbestand ist klar?
Wie rette ich dann meinen Grossen? blunk

Danke dafür, dass ihr meinen Bruder ersetzt.

Antworten
Update vollständig ausführen
isegrim (unangemeldet), Dienstag, 14. April 2009 14:22:30
Ein/Ausklappen

Wenn Du pingen kannst, hast Du Internet. Vermutlich hilft es, das Update zu wiederholen (und zu Ende zu führen).


Bewertung: 246 Punkte bei 31 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
IPv6
Icewiener (unangemeldet), Dienstag, 07. April 2009 21:34:58
Ein/Ausklappen

Mit Firefox gabs mal ein IPv6-Problem mit genau der geschilderten Folge. Gib mal in die Adresleiste von Iceweasel "about:config" ein, such dann nach "ipv6" und ändere "false" neben den Eintrag "network.dns.disableIPv6" in "true". Dann versuchs nochmal.


Bewertung: 246 Punkte bei 31 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Internet
Dieter (unangemeldet), Dienstag, 07. April 2009 19:44:26
Ein/Ausklappen

Erst mal solltest Du versuchen das Update noch mal aufzunehmen bzw abzuschließen.

synaptic oder adept oder apt-get von der console mal versuchen. Diese geben da etwas mehr Auskunft.

Es könnte sein, dass Du grad bei Teilen der Firewall oder vielleicht Proxi oder Firefox/Icewaeasel abgebrochen hast. Und wie hast du es abgebrochen? Den Button "Abbrechen" gedrückt, Beenden gewählt, oder gar Netzteil und Akku gezogen (die hardcore methode)?

Du könntest auch das Paket w3m installieren, ein Textwebkonsolenbrowser, ob dieser etwas macht.


Bewertung: 212 Punkte bei 31 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Nameserver
Marcel Hilzinger, Montag, 06. April 2009 19:52:03
Ein/Ausklappen

Vermutlich ein Nameserverproblem. Schau mal auf dem Eee-PC nach, was in der Datei /etc/resolv.conf steht und trag den Nameserver auf dem Debian-Rechner in die Datei /etc/resolv.conf ein.




Bewertung: 228 Punkte bei 32 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Nameserver
Daniel Gultsch, Montag, 06. April 2009 23:20:49
Ein/Ausklappen

Im ersten Moment hab ich auch sofort DNS gedacht. Aber wenn google angepingt werden kann, also der Hostname google.de (Und nicht eine der IPs) dann kann es nicht an DNS liegen. Trotzdem schadet es nicht die resolve.conf mal zu checken.

Wie lautet denn der genaue Fehler von Iceweasle / Icedove? Server Bla konnte nicht gefunden werden? Oder Zeitüberschreitung?

Versuch mal syn-pings (Mein neues Hobby) Dazu installierst du hping3 und machst als root mal hping3 www.google.de --syn -p 80
Kommt gar keine Antwort obwohl vorher ICMP Pings ("Normale" pings) gingen dann: Komische Firewall. Kommen RA Antworten irgendwas ganz komisches. Kommen SA Antworten dann ist alles fein. Dann versuch mal mit telnet www.google.de 80 direkt ne Verbindung aufzubauen.

Gruß Daniel


Bewertung: 253 Punkte bei 27 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Nameserver
Andreas Dollenbacher, Dienstag, 07. April 2009 07:36:39
Ein/Ausklappen

Hallo ein bisßchen wenig Hintergrundinfo,

aber OK- hast du für ein Spass mal per kabel verbunden und einen Ersatz Internet Browser genommen.
Kannst du mit anderen Diensten ins Internet? E-mail ?

Bei Wlan hatte ich schon mal das Problem , dass er versucht hatte , mich mit dem Nachbarrouter zu verbinden. (ging logischer weiße nicht ) Aber du sagst Verbindungsbalken zeigt Verbindung an?

In der Taskleiste ist doch das NetzwerkManager-applet mit Verbindungsbalken sichtbar. Wenn du ihn mit rechts anklickst, was zeigt er denn unter Verbindungsinformationen.

Stimmt WPA/? Verschlüsselung noch ?

Nameserverproblem?

Nach dem sagen wir mal Absturz Obergau , was sagt denn dein Paketmanager.
Mein Freund hatte mal so ein ähnliches Problem. Auf den ersten Blick ging nur Internet nicht , aber beim näheren Hinsehen war dann der Paketmanager komplett von der Rolle!


Gruß Andreas
P.S. jetzt weist du wichtig ein Bruder im Leben ist :-)




Bewertung: 225 Punkte bei 27 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Nameserver
Thomas (unangemeldet), Dienstag, 07. April 2009 13:32:43
Ein/Ausklappen

Ohne konkrete Daten und z.B. ein Auszug aus einem Log ist das Rätselraten eher zufällig zielführend als wirklich hilfreich.

Abgesehen von den fehlenden Daten könnte eventuelle diese Aussage auf die Ursache des Problems hindeuten:

> Vor kurzem nun habe ich laufende updates unterbrochen, und am
> nächsten Morgen wars dann so weit: Internet ging nicht mehr.

da unbekannt ist, welche Updates gerade liefen, als die Unterbrechung erfolgte (Merke: so etwas sollte man nicht tun - ausser man weiss, wie man mit den Konsequenzen umgehen muss!) ... wäre denkbar, dass die Unterbrechnung ein inkonsistentes System geschaffen hat.

Also ab in die Konsole, syslog etc. überprüfen. "dmesg" könnte eventuell schon erste Hinweise geben, ansonsten das syslog in /var/log/.

Und natürlich den Status des Paketmanagers überprüfen und ggfls. reparieren, zumindest soweit das ohne Internet möglich ist. Ein "sudo apt-get check" oder "sudo apt-get install" sollte eventuelle Fehler anzeigen und normalerweise auch Hinweise zur Abhilfe anzeigen.

Mit konkreten Informationen aus den o.g. Schritten über die festgestellten Probleme ist Hilfestellung dann kein Orakelspruch mehr sondern ganz konkret und gezielt möglich.

-Thomas


Bewertung: 241 Punkte bei 28 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

MS LifeCam HD-5000 an Debian
Kay Michael, 13.04.2016 22:55, 0 Antworten
Hallo, ich versuche die oben erwähnte Cam an einem Thin Client mit Debian zu betreiben. Linux...
Import von Evolution nach KMail erzeugt nur leere Ordner
Klaus-Christian Falkner, 06.04.2016 12:57, 2 Antworten
Hallo, da ich vor einiger Zeit von Ubuntu auf Kubuntu umgestiegen bin, würde ich gerne meine E...
Sophos lässt sich nicht unter Lubuntu installieren
Chrstina Turm, 30.03.2016 20:56, 3 Antworten
Hi Leute, habe mir vor paar Tagen auf ein Notebook, das ohne Linux ausgedient hätte, Linux dr...
Novell Client auf Raspbian
Chris Baum, 16.03.2016 15:13, 3 Antworten
Hallo Community, ich hätte eine Frage, und zwar geht es um folgendes: Ich möchte eine Datei...
Pantheon konfigurieren (eOS)
John Smith, 16.03.2016 13:50, 0 Antworten
Hallo ins Forum, ich bin neu in der Linuxwelt und fühle mich bereits sehr wohl. Mein neues Sys...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Drucker Brother dcp-195c
Frank von Thun, 30.04.2016 11:30
Am 30.04.2016 um 10:34 schrieb Christoph Walter: > > Hallo Liste,> > bis gestern funktioniert...
Re: [EasyLinux-Ubuntu] Drucker Brother dcp-195c
Hartmut Haase, 30.04.2016 11:26
Hallo Christoph, und hast Du die Verbindung kontrolliert? -- Viele Grüße, Hartmut Christoph Walter sc...
[EasyLinux-Ubuntu] Drucker Brother dcp-195c
Christoph Walter, 30.04.2016 10:34
Hallo Liste, bis gestern funktionierte mein Drucker einwandfrei. Heute kommt - bei localhost:631 - die Meld...
Re: [EasyLinux-Ubuntu] kaffeine
Wolfgang Voelker, 29.04.2016 15:24
Hallo Frank, Hallo Liste, Am 29.04.2016 um 14:37 schrieb Frank von Thun: > Am 29.04.2016 um 10:55 schrie...
Re: [EasyLinux-Ubuntu] Abbruch vom normalen Update(abgebrochen)
Frank von Thun, 29.04.2016 15:01
Am 27.04.2016 um 09:20 schrieb Uwe Herrmuth: > Hallo Frank, > Dann würde ich wie hier > beschri...