Ade, Internet. Trotz Verbindung mit Internet..

Autor

Montag, 06. April 2009 17:05:05


Liebe Community

Das nennt sich das erste Mal, das hier oder in einer vergleichbaren Community üerhaupt Fuss gefasst wird. Mittlerweile hat Linux auch mir ans Bein gepisst blunk

Das Problem beginnt damit, dass mein Bruder seine Wochen im Militär absitzt. Nicht nur unschön für ihn, sondern auch unschön für mich, weil ebenjener Bruder die Linux-Fäden bei uns zuhause in der Hand hat. Probleme gibt es solange keine, wie Brüder in der Nähe sind, die die Materie im Griff haben. Da nun dieser einzige abwesend ist, macht sich Hilflosigkeit breit; seit der Rundumschlag gegen Gates erfolgt ist, können Probleme wie das folgende nicht mehr selbst gelöst werden:
(vorneweg gestellt: mein Linux-Wortschatz begrenzt sich auf gnome-terminal, aptitude upgrade, debian und kernel - verzeiht also unschön Ausgedrücktes..)

Im eigenen Besitz sind zum einen ein Laptop, zum anderen ein Netbook (eeepc); beide mit Linux ausgestattet. Internet gibts grundsätzlich wireless. Sorgenkind ist nun der Laptop. Debian, das sich dort darauf befindet (etch testing) funktioniert alles in allem. Vor kurzem nun habe ich laufende updates unterbrochen, und am nächsten Morgen wars dann so weit: Internet ging nicht mehr.
Zumindest auf dem Laptop, gleich, dass das wirelessnetz gefunden und angewählt werden kann, und sogar die Anzeige provoziert, dass man damit befunden sei. Wird aber Iceweasle oder Icedove gestartet, tut sich so gar nichts.
Via Systemwerkzeuge-> Netzwerkdiagnose habe ich auf Geheiss meines Bruder mal einen PING ruausgeschickt, Freund google konnte so gefunden werden (trotz streikendem Iceweasle).
Das Spiel im terminal (/etc/init.d/networking force-reload) hat nichts genutzt, ebensowenig der Versuch, einen alten Kernel beim Aufstarten auszuwählen um zu versuchen, dort die unterbrochenen updates nochmals durchzuziehen.

Die Ironie an der ganzen Sache ist, dass das Internet mit dem Netbook weiterhin tadellos läuft.

Tatbestand ist klar?
Wie rette ich dann meinen Grossen? blunk

Danke dafür, dass ihr meinen Bruder ersetzt.

Baba Lussi

7 Antworten


Antworten
Update vollständig ausführen
isegrim (unangemeldet), Dienstag, 14. April 2009 14:22:30
Ein/Ausklappen

Wenn Du pingen kannst, hast Du Internet. Vermutlich hilft es, das Update zu wiederholen (und zu Ende zu führen).


Bewertung: 135 Punkte bei 14 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
IPv6
Icewiener (unangemeldet), Dienstag, 07. April 2009 21:34:58
Ein/Ausklappen

Mit Firefox gabs mal ein IPv6-Problem mit genau der geschilderten Folge. Gib mal in die Adresleiste von Iceweasel "about:config" ein, such dann nach "ipv6" und ändere "false" neben den Eintrag "network.dns.disableIPv6" in "true". Dann versuchs nochmal.


Bewertung: 122 Punkte bei 13 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Internet
Dieter (unangemeldet), Dienstag, 07. April 2009 19:44:26
Ein/Ausklappen

Erst mal solltest Du versuchen das Update noch mal aufzunehmen bzw abzuschließen.

synaptic oder adept oder apt-get von der console mal versuchen. Diese geben da etwas mehr Auskunft.

Es könnte sein, dass Du grad bei Teilen der Firewall oder vielleicht Proxi oder Firefox/Icewaeasel abgebrochen hast. Und wie hast du es abgebrochen? Den Button "Abbrechen" gedrückt, Beenden gewählt, oder gar Netzteil und Akku gezogen (die hardcore methode)?

Du könntest auch das Paket w3m installieren, ein Textwebkonsolenbrowser, ob dieser etwas macht.


Bewertung: 116 Punkte bei 14 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Nameserver
Marcel Hilzinger, Montag, 06. April 2009 19:52:03
Ein/Ausklappen

Vermutlich ein Nameserverproblem. Schau mal auf dem Eee-PC nach, was in der Datei /etc/resolv.conf steht und trag den Nameserver auf dem Debian-Rechner in die Datei /etc/resolv.conf ein.




Bewertung: 144 Punkte bei 14 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Nameserver
Daniel Gultsch, Montag, 06. April 2009 23:20:49
Ein/Ausklappen

Im ersten Moment hab ich auch sofort DNS gedacht. Aber wenn google angepingt werden kann, also der Hostname google.de (Und nicht eine der IPs) dann kann es nicht an DNS liegen. Trotzdem schadet es nicht die resolve.conf mal zu checken.

Wie lautet denn der genaue Fehler von Iceweasle / Icedove? Server Bla konnte nicht gefunden werden? Oder Zeitüberschreitung?

Versuch mal syn-pings (Mein neues Hobby) Dazu installierst du hping3 und machst als root mal hping3 www.google.de --syn -p 80
Kommt gar keine Antwort obwohl vorher ICMP Pings ("Normale" pings) gingen dann: Komische Firewall. Kommen RA Antworten irgendwas ganz komisches. Kommen SA Antworten dann ist alles fein. Dann versuch mal mit telnet www.google.de 80 direkt ne Verbindung aufzubauen.

Gruß Daniel


Bewertung: 168 Punkte bei 13 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Nameserver
Andreas Dollenbacher, Dienstag, 07. April 2009 07:36:39
Ein/Ausklappen

Hallo ein bisßchen wenig Hintergrundinfo,

aber OK- hast du für ein Spass mal per kabel verbunden und einen Ersatz Internet Browser genommen.
Kannst du mit anderen Diensten ins Internet? E-mail ?

Bei Wlan hatte ich schon mal das Problem , dass er versucht hatte , mich mit dem Nachbarrouter zu verbinden. (ging logischer weiße nicht ) Aber du sagst Verbindungsbalken zeigt Verbindung an?

In der Taskleiste ist doch das NetzwerkManager-applet mit Verbindungsbalken sichtbar. Wenn du ihn mit rechts anklickst, was zeigt er denn unter Verbindungsinformationen.

Stimmt WPA/? Verschlüsselung noch ?

Nameserverproblem?

Nach dem sagen wir mal Absturz Obergau , was sagt denn dein Paketmanager.
Mein Freund hatte mal so ein ähnliches Problem. Auf den ersten Blick ging nur Internet nicht , aber beim näheren Hinsehen war dann der Paketmanager komplett von der Rolle!


Gruß Andreas
P.S. jetzt weist du wichtig ein Bruder im Leben ist :-)




Bewertung: 139 Punkte bei 11 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Nameserver
Thomas (unangemeldet), Dienstag, 07. April 2009 13:32:43
Ein/Ausklappen

Ohne konkrete Daten und z.B. ein Auszug aus einem Log ist das Rätselraten eher zufällig zielführend als wirklich hilfreich.

Abgesehen von den fehlenden Daten könnte eventuelle diese Aussage auf die Ursache des Problems hindeuten:

> Vor kurzem nun habe ich laufende updates unterbrochen, und am
> nächsten Morgen wars dann so weit: Internet ging nicht mehr.

da unbekannt ist, welche Updates gerade liefen, als die Unterbrechung erfolgte (Merke: so etwas sollte man nicht tun - ausser man weiss, wie man mit den Konsequenzen umgehen muss!) ... wäre denkbar, dass die Unterbrechnung ein inkonsistentes System geschaffen hat.

Also ab in die Konsole, syslog etc. überprüfen. "dmesg" könnte eventuell schon erste Hinweise geben, ansonsten das syslog in /var/log/.

Und natürlich den Status des Paketmanagers überprüfen und ggfls. reparieren, zumindest soweit das ohne Internet möglich ist. Ein "sudo apt-get check" oder "sudo apt-get install" sollte eventuelle Fehler anzeigen und normalerweise auch Hinweise zur Abhilfe anzeigen.

Mit konkreten Informationen aus den o.g. Schritten über die festgestellten Probleme ist Hilfestellung dann kein Orakelspruch mehr sondern ganz konkret und gezielt möglich.

-Thomas


Bewertung: 142 Punkte bei 13 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 0 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Nach Ubdates alles weg ...
Maria Hänel, 15.11.2014 17:23, 4 Antworten
Ich brauche dringen eure Hilfe . Ich habe am wochenende ein paar Ubdates durch mein Notebook von...
Brother Drucker MFC-7420
helmut berger, 11.11.2014 12:40, 1 Antworten
Hallo, ich habe einen Drucker, brother MFC-7420. Bin erst seit einigen Tagen ubuntu 14.04-Nutzer...
Treiber für Drucker brother MFC-7420
helmut berger, 10.11.2014 16:05, 2 Antworten
Hallo, ich habe einen Drucker, brother MFC-7420. Bin erst seit einigen Tagen ubuntu12.14-Nutzer u...
Can't find X includes.
Roland Welcker, 05.11.2014 14:39, 1 Antworten
Diese Meldung erhalte ich beim Versuch, kdar zu installieren. OpenSuse 12.3. Gruß an alle Linuxf...
DVDs über einen geeigneten DLNA-Server schauen
GoaSkin , 03.11.2014 17:19, 0 Antworten
Mein DVD-Player wird fast nie genutzt. Darum möchte ich ihn eigentlich gerne abbauen. Dennoch wür...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] muon-discover
Heiko, 25.11.2014 00:47
Am Montag, 24. November 2014, 22:52:50 schrieb Sibylle Hahn: Hallo Sibylle. > Vielen Dank für die Antwor...
Re: [EasyLinux-Ubuntu] Palm Tungsten T3
Alfred Zahlten, 25.11.2014 00:13
Am 24.11.2014 um 09:13 schrieb Hartmut Haase: Hallo Hartmut, >> Oder meinst Du Bilder auf die SD Kart...
Re: [EasyLinux-Ubuntu] [Problem_gelöst]_Warnung:_No_support_for_locale:_de_DE.utf8
Alfred Zahlten, 24.11.2014 23:57
Am 24.11.2014 um 06:16 schrieb Wolfgang Voelker: Hallo Wolfgang, > Alfred Zahlten schrieb am 23.11.2014:...
Re: [EasyLinux-Ubuntu] [erledigt]_Terminal_schlißt__automatisch
Alfred Zahlten, 24.11.2014 23:11
Am 21.11.2014 um 14:44 schrieb Richard Kraut: Hallo Richard, > Nutzt Du den normalen Updater von Mint?...
Re: [EasyLinux-Ubuntu] muon-discover
Sibylle Hahn, 24.11.2014 22:52
Vielen Dank für die Antworten und Hilfe. Auf meinem frisch installiert Rechner findet sich unter "An...