Absturz SuSE 8.1 und 8.2

Ansgar Stalbold - Mittwoch, 23. Februar 2005 12:00:09 - 9 Antworten

Hallo,

ich habe ein mir unerklärliches Fenomen bei meinen SuSE Linux 8.1 u. 8.2 Servern.
Nach einigen Tagen stürzen die Server einfach ab, es gibt keine Logeinträge gar nichts. Es blinken nur die Num und Capslock leuchte.
Das habe ich mit allen 8.1 und 8.2 Servern. Die sind alle identisch installiert. Dort laufen folgende Daemons: Samba, Apache, Squid, Bind, SSH, und XNTP.
Es kann mal sein das ein Server 3-4 Tage läuft, es kommt aber auch vor das ein Server nur einen Tag läuft.
Ich habe dafür keine Erklärung, hat da jemand vielleicht eine Idee?

Antworten
Re: Absturz SuSE 8.1 und 8.2
Andreas Matthus, Mittwoch, 23. Februar 2005 21:57:15
Ein/Ausklappen

Hallo Ansgar,

Das Blinken heißt "kernel Panic". Wenn man einen laufenden Konsolenmonitor hat, kann man eventuell die letzte Meldung vom Absturz noch auf dem Bildschirm sehen ohne dass dies je in ein Logfile kommen kann.

Die Ursache kann in der Hardware, in der Software, oder in Hardware und Software liegen. In der Regel liegt es an der Hardware, wobei man bei den Distributoren mit ihren massengepatchten Kerneln nie weiß.

In Frage kämen Beispielsweise Überhitzung von bspw. CPU oder GPU/Graka. Ein häufiger Kandidat ist der RAM (es kann ja theoretisch) schon reichen, wenn von über 2.000.000.000 Bits eins kaputt ist). Vielleicht ist einfach der L1 oder L2 Cache hinüber.

Auf alle Fälle sollte auf Servern kein X laufen. Dann ist schon eine Fehlerquelle weniger. Den RAM kann man mal mit Memtest untersuchen. Die CPU-Lüfter mal physich anschauen. Ist in letzter Zeit irgendwas an Patches oder neuer Software eingespielt worden?

mfg
Andreas


Bewertung: 155 Punkte bei 39 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Absturz SuSE 8.1 und 8.2
Ansgar Stalbold, Donnerstag, 24. Februar 2005 16:28:52
Ein/Ausklappen

Hi @all,

alle Server haben exakt die gleiche Hardware! alles identisch. Auf den Server läuft ein SuSE Linux 8.2 Pro in minimal Installation. haben nur die obengenannten Dienste nachinstalliert. Und natürlich die Konfig Files angepasst.
Sonst laufen dort keine Dienste, Scripte hab ich auch nicht (zumindest keine von mir erstellten oder installierten)
Es läuft auch kein X-Server Grafik Geraffel.

Habe auch seit der installation keinerlei Patches installiert...

Ich kann mir auch nicht vorstellen das dort die Hardware defekt ist, bei allen der selbe Fehler halte ich für sehr unwahrscheinlich.
Mit SuSE 9.2 hab ich die Fehler nicht.

Ich kann mir leider auch nach dem Absturz nicht mehr die consolen anschauen weil der server sich ja aufgehangen hat...
... alles dunkel! ;-)

ich hab mir ein kleines Workaround gebaut in dem ich die Server per Cronjob jeden morgen einmal rebooten lasse um 6 Uhr. Das hat die Abstürze schon merklich reduziert. Ändert allerdings nichts am Problem (leider)

Ich werde bei ein zwei Servern nochmal die Hardware checken, vielleicht find ich ja doch noch was.

Wenn ihr noch ne idee habt wäre ich euch dankbar.


Bewertung: 137 Punkte bei 40 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Absturz SuSE 8.1 und 8.2
Andreas Matthus, Freitag, 25. Februar 2005 06:53:17
Ein/Ausklappen

Hallo Ansgar,

irgendwas verschweigst Du noch :-;
Was heißt: "Mit SuSE 9.2 hab ich die Fehler nicht."? Hast Du noch identische Konfigurationen mit einer 9.2 oder gar auf den gleichen Maschinen diese probiert? Was hindert dann um Update? Welche Kernelversionen laufen?

Kann es sein, dass sich jemand in die Systeme eingeschlichen hat? Wie scharf ist die Firewall geschaltet? Was sagen die Firewall-Log-Files (Ich kann mir nicht vorstellen, dass es einen ständig erreichbaren Server im Internet gibt, der _nicht_ permanent attakiert wird; es sei denn, er liegt schon hinter einer guten Firewall und selbst dann wird auf den offenen Ports [z. B. ssh] nach "Schwachstellen" gesucht).

Haben die Kisten womoglich identische Paßwörter? Die sollte man umgehend ändern und einen root-Kit-hunter ansetzen. Kann ja sein, dass nicht Du, sondern ein "Gast" neue Software installiert hat (Dann viel Spaß!).

Stürzen die Maschinen auch ab, wenn sie vom Netz getrennt sind?

mfg
Andreas


Bewertung: 134 Punkte bei 34 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Absturz SuSE 8.1 und 8.2
Ansgar Stalbold, Freitag, 25. Februar 2005 08:58:39
Ein/Ausklappen

Hi Andreas,

genau das hab ich gemacht, habe mir den Testserver (ist identisch mit den Problemservern) geschnappt und dort ein SuSE 9.2 inst. mit den selben Diensten und der selben Konfiguration soweit möglich.
Um Updates einzuspielen muss ich zu den Servern fahren, ist einfach eine Zeitfrage und die Dienste laufen ja (eigentlich...).
Auf den Kisten läuft ein SuSE Kernel 2.4.20.
Ich werde aber mal an einem Standort die Patches einspielen, vielleicht bringt das ja Besserung.

Es kann natürlich sein das sich jemand eingeschlichen hat, will ich nicht ausschliessen, konnte dafür aber keine Anzeichen erkennen. Die Server stehen alle hinter Cisco Firewalls. Es gibt keinen Zugriff von aussen.

Vom Netzgenommen hab ich die Kisten noch nie, könnte ich über Ostern mal testen.

Danke


Bewertung: 127 Punkte bei 41 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Absturz SuSE 8.1 und 8.2
Andreas Matthus, Sonntag, 27. Februar 2005 18:44:39
Ein/Ausklappen

Hallo Ansgar,

dass Du dran bleibst finde ich gut. Und die Sicherung durch eine Cisco auch. Wird deren Log-Datei auch mal gelesen?

Unverständlich, warum Du zu den Maschinen fahren musst, um ein update zu machen. yast im Textmodus geht wunderbar über ssh.

mfg
Andreas


Bewertung: 115 Punkte bei 34 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Absturz SuSE 8.1 und 8.2
Ansgar Stalbold, Mittwoch, 09. März 2005 17:26:07
Ein/Ausklappen

Hi,

die LogDateien bekomme ich einmal pro Woche und in der Regel kontrolliere ich die auch, hab dafür ein kleines Prog.
Ist bisher aber nichts auffälliges drin, das war auch mein erster Gedanke bei den abstürzen.

Das sind keine Standleitungen und die Ciscos können kein DynDNS, auf jedenfall konnte ich die Biester dazu nicht überreden.

Bei Updates auf Servern bin ich lieber vor Ort.


Bewertung: 81 Punkte bei 37 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Absturz SuSE 8.1 und 8.2
rottriges , Mittwoch, 23. Februar 2005 13:30:05
Ein/Ausklappen

Hallo,

ich glaube, dass dein Problem nicht softwaretechnisch ist sondern eher physischer Natur.
Wenn wirklich alle Server gleichzeitig abstürzen und es keine Logeinträge gibt, dann tippe ich darauf, dass mit deiner Stromversorgung etwas nicht stimmt. Sind die Server an eine USV-Anlage angeschlossen? Ich würde probehalber mal einen Server an einen seperate Stromkreis anschließen. (Falls das möglich ist)




Bewertung: 117 Punkte bei 39 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Absturz SuSE 8.1 und 8.2
Ansgar Stalbold, Mittwoch, 23. Februar 2005 18:03:57
Ein/Ausklappen

sorry, ich hab mich wohl ein wenig unglücklich ausgedrückt bzw. was vergessen. Hier die Ergänzung:

Die Server stehen an unterschiedlichen Standorten/Gebäuden. Sie stürzen nicht alle zur gleichen Zeit ab, sondern völlig zufällig (wenn sie gerade mal keine lust haben...) Der Fehler tritt mit und ohne USV auf.
Auf meinem Testserver (identisch mit den Problemservern) hab ich die Probleme mit SuSE 9.2 bisher nicht, ein Update auf 9.2 ist zur Zeit bzw. in nächster Zeit nicht möglich.

ich habe keine idee mehr...


Bewertung: 196 Punkte bei 40 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Absturz SuSE 8.1 und 8.2
rottriges , Donnerstag, 24. Februar 2005 08:07:51
Ein/Ausklappen

Wenn es ein Hardwaredefekt wäre müssten ja zufällig alle Server, die auch noch an unterschiedlichen Orten stehen gleichzeitig einen (möglicherweise noch den gleichen) Schaden haben.
Rein logisch betrachtet kann ich mir das aber nicht vorstellen. Das wäre schon ein großer Zufall.
Um eine genauere Diagnose zu erstellen (wenn diese überhaupt möglich ist), bräuchte man noch ein paar Angaben.

Da das Phänomen bei allen Servern auftritt, wäre es interessant zu wissen, ob auch alle Server exakt baugleich sind.
Wenn nicht, welche Hardware ist identisch? (z.B in jeden Server ist der gleiche Raidcontroller usw.)
Wenn das zu keiner Lösung führt, würde ich den oberen Ansatz auch in Bezug auf die Software anwenden. Angefangen bei "exotischen" Diensten bzw. Programmen über selbstgeschriebene Scripts/Programme bis hin zu den Standartprogrammen. (genau in der Reihenfolge und immer den Focus auf die Gemeinsamkeit legen)

Meine Vermutung nach bisherigen Kenntnisstand:
Bei deinen Servern läuft irgendein Script, Treiber oder Programm, welches auf jeden Server installiert ist, aus dem Ruder.

Ich hoffe einen Denkanstoß gegeben zu haben.

gruß rottriges


Bewertung: 103 Punkte bei 36 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Mysteriöse Linux-Abstürze beim Jahreswechsel
    Einige Server-Admins haben beim Jahreswechsel 2008-2009 um Mitternacht Abstürze von Linux-Servern beobachtet. Die Kernel-Entwickler untersuchen derzeit, ob das Phänomen mit der Schaltsekunde zusammenhängt.
  • The Answer Girl
    Nervt die CapsLock-Taste? Suchen Sie einen sinnvollen Verwendungzweck für die Windows-Tasten? Alles eine Frage der Definition …
  • KDE 3.4 im Überblick
    Wieder einmal dreht sich das Zahnrad von KDE um einen Zacken. Die Entwickler gaben zur Cebit das Release der Version 3.4 heraus. Dieser Artikel stellt Ihnen die interessantesten Neuerungen der Desktop-Umgebung vor und zeigt, wie Sie sie nutzen.
  • OpenSuse-Server über das Wochenende außer Betrieb
    Kein Terroranschlag sondern ein Update an den Transformatoren des Nürnberger Office sorgen am kommenden Wochenende für einen mehrtägigen Ausfall der wichtigsten Dienste des OpenSuse-Projekts.
  • Suse kooperiert weiter mit Microsoft

    Suse kooperiert weiter mit Microsoft, sowohl in Sachen Server-Lizenzen als auch bei der Produktentwicklung.

Aktuelle Fragen

Wie kann man das berichtigen
Udo Muelle, 17.07.2016 20:39, 1 Antworten
Fehlschlag beim Holen von http://extra.linuxmint.com/dists/rosa/main/binary-i386/Packages Hash-S...
Installation Genimotion
Horst Müller, 15.07.2016 17:00, 1 Antworten
Hallo, ich kann Genimotion nicht installieren. Folgende Fehlermeldung habe ich beim Aufruf erh...
Probleme beim Hochfahren der Terastaion 5400 mit Unix-Distrib
Sheldon Cooper, 10.07.2016 09:32, 0 Antworten
Hallo ihr lieben, habe seit zwei Tagen das Problem, das das NAS (Raid5) nicht mehr sauber hoch...
Mit Firewire Videos improtieren?
Werner Hahn, 09.06.2016 11:06, 5 Antworten
Ich besitze den Camcorder Panasonic NV-GS330, bei dem die Videos in guter Qualität nur über den 4...
lidl internetstick für linux mint
rolf meyer, 04.06.2016 14:17, 3 Antworten
hallo zusammen ich benötige eure hilfe habe einen lidl-internetstick möchte ihn auf linux mint i...

Jetzt auf den Mailinglisten

[EasyLinux-Ubuntu] KeePassX: Fehler beim Login mit Tastenkombination
Rainer, 25.07.2016 11:10
Hallo zusammen, vor Langem funktionierte nach Installation der Anwendung das Einloggen per Tastenkombinatio...
[EasyLinux-Ubuntu] OT: Suche Internet-Anbieter mit bestimmten Kriterien
Michael, 25.07.2016 10:31
Hallo, mal ein kleines OT, bei dem ich hoffe, jemand kann mir Tipps geben: Ich suche derzeit nach einem Anb...
[EasyLinux-Ubuntu] Fritzbox
alfred, 24.07.2016 21:14
Hallo Rainer, eine gebrauchte FritzBox ohne Rückgaberecht, Garantie und Handbuch liegt nun hier. Ein Han...
Re: [EasyLinux-Ubuntu] Teamviewer: Fernsteuerung und Videokommunikation gleichzeitig
Rainer, 24.07.2016 21:13
Hallo Karl-Heinz, Am Sat, 23 Jul 2016 08:47:41 +0200 schrieb Karl-Heinz : > > ich glaube, dass w...
Re: [EasyLinux-Ubuntu] KMail und MDA
Uwe Herrmuth, 24.07.2016 20:51
Hallo Steffen, Steffen Weyh schrieb am 23.07.2016 um 12:11: > Nicht gut! > Welche anderen Möglichke...