2 Betriebssysteme opSuse11.4 auf einem PC

Lin nel - Dienstag, 20. September 2011 11:54:46 - 1 Antworten

Hallo Linux-Community, seit Jahren (opSuse9.x) betreibe ich neben meinem Standardbetriebssystem (jetzt opSuse11.4) auf einer separaten Partition ein weiteres Betriebssystem (z.Z. auch 11.4) für Tests etc.. Das klappte auch immer gut. Im Bootlader konnte ich beide Systeme aufführen und so beim Hochfahren wählen.
Seit einiger Zeit führt eine Neuinstallation in eine der Partitionen dazu, dass die andere Partition (sollte eigentlich bei der Installation nicht berührt werden; P.- Manager: Partition nicht eingehängt, nicht F) anscheinend in Mitleidenschaft gezogen wird.
Beim Booten in das ältere system gibt es dann jede Menge Fehlermeldungen (Modul ata1.01 failed; Fatal could not load /lib/modules/2.6.3...- no such file; perhaps itables or Kernel needs upgrade); System startet zwar aber viele Funktionen laufen nicht mehr (kein DSL, kein USB-Zugriff auf ext. FP oder -Stick.
Kann man beim Booten etwas beeinflussen? Ich habe den Eindruck der passende Bootlader (oder Bootdateien) für das früher installierte System wird nicht aufgerufen. (Beim Neuinstallieren kommt der Hinweis, dass Probleme möglich wären; das neu installierte System läuft aber problemlos.)
Hat jemand einen Tipp für mich?
Gruß LiNel

Antworten
Bootlader-Einstellungen unter YaST
Lin nel, Dienstag, 20. September 2011 13:24:50
Ein/Ausklappen

Ich habe gerade die Lösung gefunden:
unter YaST / Bootlader-Einstellungen / Abschnittsverwaltung => Auswahlfeld "weitere".
Dort kann eine Konfiguration automatisch erstellt werden; alle Betriebssysteme werden erkannt und die richtigen Einstellungen werden vorgeschlagen. Mein Problem ist also beseitigt!
(Man darf nicht den Abschnit klonen, sondern muss über Menüabschitt und Menübeschreibungsdatei gehen...)
Grüße LiNel


Bewertung: 272 Punkte bei 17 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Probleme mit MPC/MPD
Matthias Göhlen, 27.09.2016 13:39, 0 Antworten
Habe gerade mein erstes Raspi Projekt angefangen, typisches Einsteigerding: Vom Raspi 3B zum Radi...
Soundkarte wird erkannt, aber kein Ton
H A, 25.09.2016 01:37, 6 Antworten
Hallo, Ich weiß, dass es zu diesem Thema sehr oft Fragen gestellt wurden. Aber da ich ein Linu...
Scannen nur schwarz-weiß möglich
Werner Hahn, 20.09.2016 13:21, 2 Antworten
Canon Pixma MG5450S, Dell Latitude E6510, Betriebssyteme Ubuntu 16.04 und Windows 7. Der Canon-D...
Meteorit NB-7 startet nicht
Thomas Helbig, 13.09.2016 02:03, 4 Antworten
Verehrte Community Ich habe vor Kurzem einen Netbook-Oldie geschenkt bekommen. Beim Start ersch...
windows bootloader bei instalation gelöscht
markus Schneider, 12.09.2016 23:03, 1 Antworten
Hallo alle zusammen, ich habe neben meinem Windows 10 ein SL 7.2 Linux installiert und musste...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Bildbetrachtungsprogramm (KDE) mir Druckfunktion
Heiko, 28.09.2016 00:02
Am Dienstag, 27. September 2016, 01:46:26 CEST schrieb alfred: Hallo Michael,hallo Alfred > > >...
Re: [EasyLinux-Ubuntu] [gelöst]_Thunar
Gerhard Blaschke, 27.09.2016 21:16
Am 27.09.2016 um 19:37 schrieb Karl-Heinz: > Am Tue, 27 Sep 2016 08:48:37 +0200 > schrieb Gerhard Bla...
Re: [EasyLinux-Ubuntu] Thunar
Karl-Heinz, 27.09.2016 19:37
Am Tue, 27 Sep 2016 08:48:37 +0200 schrieb Gerhard Blaschke : Hallo Gerhard, doch das geht. Hier mal ein...
Re: [EasyLinux-Suse] Firefox
Heiko, 27.09.2016 15:46
Am Dienstag, 27. September 2016, 10:46:37 CEST schrieb Horst Schwarz: Hallo, > ich war gezwungen, im Firefo...
Re: [EasyLinux-Ubuntu] Thunar
Gerhard Blaschke, 27.09.2016 08:48
Am 27.09.2016 um 08:21 schrieb Uwe Herrmuth: > Hallo Gerhard, > > Gerhard schrieb am 26.09.2016...