openSUSE 12.3 vollständig Deutsch beibringen

Aktualisierung der Pakete unter openSUSE
Aktualisierung der Pakete unter openSUSE
09.04.2013 13:38

Die openSUSE Live-CDs kommen standardmäßig in English. Selbst wenn man von ihnen ein deutsches openSUSE installiert, fehlen anschließend im fertigen System ein paar Übersetzungen. Das lässt sich jedoch mit wenigen Handgriffen beheben.

Die fehlenden deutschen Sprachpakete holt man am Schnellsten über die Kommandozeile nach. Dazu öffnet man ein Terminal-Fenster (unter KDE im Startmenü auf dem Register Favorites über den Punkt Terminal, unter GNOME öffnet man die Activities, tippt terminal ein und drückt die Eingabetaste). Dort setzt man jetzt folgende drei Befehle ab:

su root
zypper inr
zypper dup

Alle Befehle sind über die Eingabetaste abzuschicken. Nach dem ersten Kommando muss man das root-Passwort eingeben (das man bei der Installation vergeben hat, häufig das eigene). Das zweite sorgt dafür, dass openSUSE alle empfohlenen und somit auch die fehlenden Sprachpakete nachholt, inr steht dabei für install recommends. Die Installation muss man explizit mit j bestätigen. Eventuell angezeigte Lizenzverträge beendet man mit [q] und bestätigt sie dann mit ja. Erhält man eine Fehlermeldung, dass noch PackageKit aktiv sei, läuft im Hintergrund sehr wahrscheinlich die Aktualisierungsverwaltung. Hier muss man nein eingeben, eine Weile warten und es dann später noch einmal versuchen.

Aktualisierung der Pakete unter GNOME

Auf manchen Installationen reicht zypper inr nicht aus. Abhilfe schafft dann laut openSUSE-Projekt zypper dup, das die Distribution auf den aktuellen Stand bringt. Auch hier muss man die Installation beziehungsweise Aktualisierung mit j bestätigen. Die Aktualisierung kann je nach Alter und Stand der Installation einige Zeit dauernd.

Während der gesamten Prozedur beschwert sich unter umständen openSUSE mit entsprechenden Meldungen, dass zypper die Paketverwaltung blockieren würde. Dies kann man jedoch einfach ignorieren. Nachdem alle Sprachpakete installiert sind, sollte man das System sicherheitshalber einmal neu starten (in KDE über das Startmenü, Leave, Restart und dann Restart Computer, unter GNOME klickt man auf seinen Namen rechts oben, dann Power Off und Restart).

Hartnäckiger Fall

Sofern die Benutzeroberfläche weiterhin nur Deutsch spricht, zückt man YaST (unter KDE über das Startmenü, Computer, YaST, im Fall von GNOME öffnet man die Activities, tippt yast ein und drückt die Eingabetaste). In ihm ruft man unter Software das Modul Software installieren oder löschen beziehungsweise Software Management auf und installiert dann die folgenden Pakete (Paketnamen in die Suche eingeben, auf Search klicken, rechts oben das Paket abhaken, am Ende auf Accept, gefolgt von Continue klicken):

  • bundle-lang-common-de
  • bundle-lang-gnome-de
  • bundle-lang-gnome-extras-de
  • MozillaFirefox-translations-common
  • MozillaThunderbird-translations-common
  • aspell-de
  • ispell-german
  • ispell-ngerman
  • libreoffice-help-de
  • libreoffice-l10n-de
  • libreoffice-languagetool-de
  • libreoffice-templates-de
  • libreoffice-thesaurus-de
  • myspell-german
  • translation-update-de
  • yast2-trans-de

Unter KDE zusätzlich noch:

  • bundle-lang-kde-de
  • kde4-l10n-de
  • kde4-l10n-de-data

Anschließend muss man sich einmal ab- und wieder anmelden (unter KDE im Startmenü Leave, Log out und dann Logout, bei GNOME mit einem Klick auf den eigenen Namen rechts oben, dann Log out und Log out).


Kommentare
Funzt nicht :(
patrickstar777 (unangemeldet), Donnerstag, 03. Juli 2014 02:04:29
Ein/Ausklappen

Bei mir auch nicht. Alle Pakete da, bei den beiden 'inr' und 'dup' befehlen werden keine Aktionen mehr ausgeführt.

Yast, Persönliche Einstellungen und Desktop-Settings heißt das glaub ich (die drei Systemsteuerungen) - überall deutsch eingestellt, trotzdem Mischmasch.

KMenü und Yast sind weiterhin auf Englisch.


Bewertung: 136 Punkte bei 75 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Funzt nicht :(
Hier dasselbe! (unangemeldet), Donnerstag, 17. Juli 2014 09:10:41
Ein/Ausklappen

ohne eigenes Zutun, Startmenü und Anmeldung in Englisch.
Alle Tipps im Netz zu Spracheinstellungen ausgeführt, jeweils einen Neustart, nichts ;(


Bewertung: 47 Punkte bei 111 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
das funkt bei so nicht
haiko2201 (unangemeldet), Montag, 24. Juni 2013 09:40:51
Ein/Ausklappen

Habe es genau so gemacht, doch es funktioniert nicht. Viele Sache sind Englisch, ich finde das schon seltsam für eine so große "alte" Distro.

Kwallet will ich password für mein Wlan, obwohl ich mich anmelde.

Nöö, ich gehe wieder zurück zu einer Debiandistro...



Bewertung: 81 Punkte bei 96 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Kommentare
Funzt nicht :(
patrickstar777 (unangemeldet), Donnerstag, 03. Juli 2014 02:04:29
Ein/Ausklappen

Bei mir auch nicht. Alle Pakete da, bei den beiden 'inr' und 'dup' befehlen werden keine Aktionen mehr ausgeführt.

Yast, Persönliche Einstellungen und Desktop-Settings heißt das glaub ich (die drei Systemsteuerungen) - überall deutsch eingestellt, trotzdem Mischmasch.

KMenü und Yast sind weiterhin auf Englisch.


Bewertung: 136 Punkte bei 75 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Funzt nicht :(
Hier dasselbe! (unangemeldet), Donnerstag, 17. Juli 2014 09:10:41
Ein/Ausklappen

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 4 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 0 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...
Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 6 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...
Treiber für Canon Laserbase MF5650
Sven Bremer, 10.02.2015 09:46, 1 Antworten
Hallo ich weiß mittlerweile das Canon nicht der beste Drucker für ein Linux System ist. Trotzd...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] kann_Datei_nicht_im_Windowsordner_per_script_löschen
Joachim Puttkammer, 30.03.2015 16:42
Am Montag, 30. März 2015 schrieb Matthias Müller: Hallo Matthias und Uwe, den Fipptehler hab ich nicht beme...
Re: [EasyLinux-Ubuntu] Midnight_Commander_[gelöst]
Alfred Zahlten, 30.03.2015 15:55
Am 30.03.2015 um 14:30 schrieb Joachim Puttkammer: > Am Montag, 30. März 2015 schrieb Uwe Herrmuth: Hall...
Re: [EasyLinux-Ubuntu] Midnight_Commander_[gelöst]
Uwe Herrmuth, 30.03.2015 15:25
Hallo Joachim, Joachim Puttkammer schrieb am 30.03.2015 um 14:30: > bin mit KDE und Konsole unterwegs un...
Re: [EasyLinux-Ubuntu] kann_Datei_nicht_im_Windowsordner_per_script_löschen
Uwe Herrmuth, 30.03.2015 15:23
Hallo Joachim, Dein Script enthält einen einfachen Schreibfehler. Joachim Puttkammer schrieb am 30.03.2015...
Re: [EasyLinux-Ubuntu] kann_Datei_nicht_im_Windowsordner_per_script_löschen
Matthias Müller, 30.03.2015 15:19
Hallo Am Montag, 30. März 2015 schrieb Joachim Puttkammer: snip > Diese Befehlsfolge ist OK, aber in e...